Bug 157849 - Client node missing in Maven Simple project
Client node missing in Maven Simple project
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: Client
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
: ERGONOMICS, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 15:54 UTC by Jaroslav Pospisil
Modified: 2009-05-20 10:29 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2009-02-03 15:54:37 UTC
Build 200902030229,Win Vista, JDK 1.6

Create new Maven Project (Simple archetype) and change sources to 1.5 .
Add new Web Service Client from this URL:  http://www.webservicex.net/CurrencyConvertor.asmx?wsdl
ERROR: No Web Service References node is created and when I Call Web Service operation,list is empty.
Comment 1 Milan Kuchtiak 2009-02-10 16:40:14 UTC
Fixed:
http://hg.netbeans.org/main?cmd=changeset;node=0690f5b6f2a0
BTW; the wsdl URL you reference here sometimes doesn't work so Netbeans doesn't create a client for it.
Comment 2 Jaroslav Pospisil 2009-02-11 10:18:48 UTC
Still reproducible in latest hudson build. Reopening.
Comment 3 Milan Kuchtiak 2009-02-18 17:33:44 UTC
Related a little with ERGONOMICS feature.

Evaluation:

maven.jaxws is a "bridge" module between JAX-WS support and Maven support in enterprise cluster.
This module registers a LookupProvider / OpenHook) for Maven projects.
When the Maven project is being open, the listener(for pom.xml file), is registered in OpenHook:projectOpened() 

In this particular situation :
When Maven project is being open - the maven cluster is activated only, not enterprise cluster
When a web service client is created (using WS Client wizard) the enterprise cluster (including maven.jaxws module) is
activated. Then, the project file(pom.xml) file is modified(some information related to WS Client is added).

Problem is that maven project is already opened, so OpenHook:projectOpened(), registered in maven.jaxws, is never
called, and listener doesn't fire the change event, since it hadn't been registered.

Tell me what to do with that ?
maven.jaxws depends on both: modules from enterprise cluster and modules from maven cluster.
Moreover, now the module is "eager" - it's automatically activated when all depending modules are activated.

We need likely to divide maven.jaxws into 2 modules.
Comment 4 Milan Kuchtiak 2009-02-23 09:46:31 UTC
The pom file listener was removed from OpenHook implementation :
http://hg.netbeans.org/main?cmd=changeset;node=ed8167aee1a3
Comment 5 Quality Engineering 2009-02-24 20:09:22 UTC
Integrated into 'main-golden', will be available in build *200902241401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ed8167aee1a3
User: mkuchtiak@netbeans.org
Log: #157849: refactor Maven JAXWS support: move pom file listener from Project OpenHook to createAdditionalLookup(), separate JaxWsOpenHook
Comment 6 Jaroslav Pospisil 2009-03-17 15:14:55 UTC
v.
Comment 7 Jaroslav Pospisil 2009-04-22 13:25:47 UTC
Reopening,since there's ws client node missing again. Workaround - reopen project.
Comment 8 Milan Kuchtiak 2009-04-24 16:42:08 UTC
JaxWsNodeFactory listener doesn't work in ergonomic case :

- Maven Web project is created/opened
- Web Services modules, including maven.jaxws, are installed

We need to hook somehow into JaxWsNodeFactory.
Comment 9 Jaroslav Tulach 2009-04-24 18:41:14 UTC
Stop by if you need help or consultation.
Comment 10 Milan Kuchtiak 2009-04-27 16:06:41 UTC
Fixed.

- LookupListener implemented to enable listener registration when project lookup is filled 
- move all stuff from JaxWsOpenHook to MavenJaxWsSupportProvider

Details:
http://hg.netbeans.org/main/rev/a16ec2b36ebd
Comment 11 Quality Engineering 2009-04-28 18:50:37 UTC
Integrated into 'main-golden', will be available in build *200904281401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a16ec2b36ebd
User: mkuchtiak@netbeans.org
Log: #157849: take out annotation listeners from OpenHook implementation, implement LookupListener in Node Factory
Comment 12 Jaroslav Pospisil 2009-05-04 14:58:50 UTC
v.
Comment 13 Jaroslav Pospisil 2009-05-04 17:04:52 UTC
It was OK-once with already used userdir. When I've tried exact steps,issue is still reproducible.
Comment 14 Jaroslav Pospisil 2009-05-04 17:14:58 UTC
Now the problem is valid also for web projects.
Comment 15 Jaroslav Pospisil 2009-05-05 11:23:39 UTC
Issue is not reproducible again in 200905050201 - closing as fixed and will try to verify next week. This issue keeps
returning again and again, cause originating from Ergonomics,so I expect to see it reopened again in future.
Comment 16 Milan Kuchtiak 2009-05-06 15:53:48 UTC
There was a bug in Maven project that likely caused the latest regression.

I also improved the listener part:
http://hg.netbeans.org/main/rev/1d842d18557d
Comment 17 Quality Engineering 2009-05-09 06:59:47 UTC
Integrated into 'main-golden', will be available in build *200905090201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/1d842d18557d
User: mkuchtiak@netbeans.org
Log: #157849: improve the listener part of the class
Comment 18 Jaroslav Pospisil 2009-05-20 10:29:11 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo