Bug 157139 - deadlock after creating groovy script (EventSupport vs Source)
deadlock after creating groovy script (EventSupport vs Source)
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All Windows Vista
: P2 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: RANDOM, THREAD
: 157635 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 14:39 UTC by Lukas Jungmann
Modified: 2009-02-25 15:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
dump (24.95 KB, text/plain)
2009-01-20 14:39 UTC, Lukas Jungmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2009-01-20 14:39:32 UTC
(parsing_api build #134)

-run some unit tests
-create new groovy script
-switch to some already opened groovy file

=> deadlock
Comment 1 Lukas Jungmann 2009-01-20 14:39:53 UTC
Created attachment 76050 [details]
dump
Comment 2 Vitezslav Stejskal 2009-02-02 11:48:07 UTC
Looks like a problem between EventSupport and Source classes.
Comment 3 Vitezslav Stejskal 2009-02-02 11:51:16 UTC
*** Issue 157635 has been marked as a duplicate of this issue. ***
Comment 4 Jan Jancura 2009-02-03 14:48:40 UTC
fixed in trunk
Comment 5 Jan Jancura 2009-02-25 15:20:16 UTC
23fa0dee1877


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo