Bug 157093 - add ArtifactCopyOnSave and CopyOnSave via J2eeModuleProvider.getDeployOnSaveSupport()
add ArtifactCopyOnSave and CopyOnSave via J2eeModuleProvider.getDeployOnSaveS...
Status: RESOLVED DUPLICATE of bug 177230
Product: javaee
Classification: Unclassified
Component: Maven
4.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: issues@javaee
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 06:29 UTC by Milos Kleint
Modified: 2010-05-12 12:01 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milos Kleint 2009-01-20 06:29:18 UTC
see subject.

the consequences are that modified jar dependencies won't trigger redeploy etc..
Comment 1 nozlarsson 2009-10-19 08:36:13 UTC
Hi there,
I followed your discussion about the deploy on save functionality (http://forums.netbeans.org/ntopic13927.html)
and found this issue.
I downloaded Netbeans 6.8 M2 and tested the deploy on save feature but it didn't work for my purposes.
I have very simple Maven JavaEE project structure. One Ear-Project, 1 War, 1 EJB. My goal is that changes I make to the war project (e.g to the xhtml) are 
automatically deployed to the application server (in my case, glassfish V2.1). A simple refresh on the browser should show the changes.
So I activated the deploy on save on both the war project and the ear project, changed something in the xhtml file but the changes aren't published.

Could you please tell me if I am doing something wrong? Or is this feature just not implemented yet?

Greetings
Daniel
Comment 2 Milos Kleint 2009-10-21 08:35:37 UTC
it's not done yet.
Comment 3 roti 2009-11-30 07:15:21 UTC
I tested it with 6.8 RC1, and not working.

Product Version: NetBeans IDE 6.8 RC1 (Build 200911252200)
Java: 1.6.0_15; Java HotSpot(TM) 64-Bit Server VM 14.1-b02
System: Linux version 2.6.31-15-generic running on amd64; UTF-8; hu_HU (nb)

The module dependencies with <type>war</type> should be auotmatically copied to the main project's target dir on CoS enabled.
Comment 4 noz 2009-12-01 15:06:01 UTC
(In reply to comment #3)
> I tested it with 6.8 RC1, and not working.
> 
> Product Version: NetBeans IDE 6.8 RC1 (Build 200911252200)
> Java: 1.6.0_15; Java HotSpot(TM) 64-Bit Server VM 14.1-b02
> System: Linux version 2.6.31-15-generic running on amd64; UTF-8; hu_HU (nb)
> 
> The module dependencies with <type>war</type> should be auotmatically copied to
> the main project's target dir on CoS enabled.

I confirm that the compile on save feature is not implemented in Netbeans 6.8 RC1. If it should work, please tell us what to do to make it work. 
Greetings
Comment 5 Antonin Nebuzelsky 2010-01-14 06:58:15 UTC
Changing the default owner to issues@javaee.
Comment 6 noz 2010-01-14 13:41:04 UTC
I am not sure what is happing with this bug. It still exists. I know that I could switch to JavaEE and change the project to deploy ejbs within a war project, which would make deploy on save work but that's no solution.
Due to this bug I can't change several projects from ant to maven.
Comment 7 Petr Jiricka 2010-05-10 15:08:59 UTC
So is this a duplicate of enhancement 177230?
Comment 8 noz 2010-05-12 12:00:48 UTC
yes, it is a duplicate of 177230.
Comment 9 noz 2010-05-12 12:01:41 UTC
duplicate

*** This bug has been marked as a duplicate of bug 177230 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo