Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 157012 - Some items not available in the OSX version of netbeans vs. the Win version. (JAVA)
Some items not available in the OSX version of netbeans vs. the Win version. ...
Status: RESOLVED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
Macintosh Mac OS X
: P3 (vote)
: 6.x
Assigned To: issues@guibuilder
issues@guibuilder
JA_COMMUNITY
:
: 176856 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-18 19:49 UTC by protean
Modified: 2009-11-15 03:07 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
properties window - no AutoCreateRowSorter (107.04 KB, image/png)
2009-08-02 12:38 UTC, Masaki Katakai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description protean 2009-01-18 19:49:49 UTC
Hello,

I'm new to java and netbeans so this may be user error :)

I've looked at a couple of database tutorials for java found on the Netbeans site and have come across a couple of
differences between netbeans on the two platforms (win32 and OSX). My primary platfrom is OSX.

Firstly the autoCreateRowSorter check box for a table isn't available in the parameter window in the OSX version
although I installed a fresh copy of the Win version at work and it's there. I can use autoCreateRowSorter in the code
if I use custom code or just hard code it it so it's not like it's not available.

Secondly, following this tutorial

http://blogs.sun.com/JavaFundamentals/entry/using_beans_binding_to_search

I got as far as trying to bind the text field to the table rowsorter but the rowsorter entry doesn't appear in the osx
version of netbeans. 

John
Comment 1 David Vancouvering 2009-01-20 19:12:40 UTC
Sorry about passing the buck again, but this looks like an issue with the visual beans binding support.  I am passing in
on to the team I *think* is responsible, it may get reassigned again :(
Comment 2 Tomas Pavek 2009-02-11 13:22:52 UTC
Isn't the difference in that on OS X you run NetBeans on JDK 5? The autoCreateRowSorter property on JTable was added in
JDK 6. The fact that you can write it in code might be that your project has JDK 6 set as target platform, however in
the GUI builder the JTable component is instantiated by the same JDK as the IDE runs on - that might be why the property
is missing. You'd need to run NetBeans on JDK 6 as well. Can you confirm this is the case?
Comment 3 protean 2009-02-12 20:56:03 UTC
Hello,

I'm not 100% sure where to find which java platform the IDE is running in.  From the  Netbeans/About Netbeans menu
I get:

Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_07; Java HotSpot(TM) 64-Bit Server VM 1.6.0_07-b06-57
System: Mac OS X version 10.5.5 running on x86_64; MacRoman; en_US (nb)

Which would indicate Java 6 no?

John
Comment 4 Tomas Pavek 2009-02-13 09:52:47 UTC
Yes, this means that NetBeans runs on Java 6. So I have no idea then.

Can you describe where exactly you see the "autoCreateRowSorter check box" missing? Is it in the properties window when
you select a JTable? I don't find it mentioned in the tutorial either...
Comment 5 pribyl 2009-06-24 12:33:13 UTC
Closing as WORKSFORME - reporter did not provide additional info for more than 4 weeks.

Protean, please reopen the issue if the problem persist and you can provide additional info (e.g. answer the tpavek's
question)

Thanks a lot 
Comment 6 Masaki Katakai 2009-08-02 12:35:15 UTC
Reopened.

I got the same report from community people and I'm also seeing that "autoCreateRowSorter" checkbox
is missing on table properties window. When I tried on Windows, it's actually visible.

NetBeans IDE 6.7.1 (Build 200907230233)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02-83
Mac OS X バージョン 10.5.7; SJIS; ja_JP (nb)
Comment 7 Masaki Katakai 2009-08-02 12:38:11 UTC
Created attachment 85658 [details]
properties window - no AutoCreateRowSorter
Comment 8 Jan Stola 2009-08-04 16:38:18 UTC
I was able to reproduce this issue. It is caused by a bug in Mac's Java 6. All meta-information about components 
(including the set of properties) is provided by corresponding BeanInfos. The BeanInfos for Swing components are stored 
in dt.jar. Unfortunately, dt.jar of Java 6 on Mac seems to be obsolete. It corresponds to Java 5 components e.g. all 
properties added in Java 6 are omitted. For example: rowSorter, autoCreateRowSorter, dropLocation and dropMode of 
JTable.

I will try to implement some workaround.
Comment 9 Jan Stola 2009-08-04 16:57:24 UTC
Fixed - new Java 6 properties should be available in Properties by now. These properties are loaded using introspection 
(not using BeanInfo). Hence, their category may not be correct (they can be placed in Other Properties instead of 
Properties).

Modified files: http://hg.netbeans.org/cdev/rev/83032ab57b2c
Comment 10 Jan Stola 2009-11-15 03:07:55 UTC
*** Bug 176856 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo