Bug 156995 - Deadlock while opening a Java file
Deadlock while opening a Java file
Status: RESOLVED DUPLICATE of bug 156443
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-17 21:11 UTC by Marian Petras
Modified: 2009-02-19 20:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
full thread-dump (generated by jstack) (28.22 KB, text/plain)
2009-01-17 21:12 UTC, Marian Petras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2009-01-17 21:11:09 UTC
I was making some trivial changes to several Java source files (open file, make a change, close the file, open second
file...) and I got a deadlock when opening one of the files:

Found one Java-level deadlock:
=============================
"OpenIDE-request-processor-1":
  waiting to lock monitor 0x08350648 (object 0x67fe4968, a org.netbeans.modules.parsing.api.Source),
  which is held by "JavaSourceTaskFactory"
"JavaSourceTaskFactory":
  waiting to lock monitor 0x08676460 (object 0x67fdd848, a org.openide.windows.CloneableOpenSupport$Listener),
  which is held by "Document Processing"
"Document Processing":
  waiting to lock monitor 0x08350648 (object 0x67fe4968, a org.netbeans.modules.parsing.api.Source),
  which is held by "JavaSourceTaskFactory"

See the attachment for a full thread-dump.

--
  Product Version         = NetBeans IDE Dev (Build 20081213032631)
  Operating System        = Linux version 2.6.24-23-generic running on i386  (Ubuntu 8.04 32-bit)
  Java; VM; Vendor        = 1.6.0_11; Java HotSpot(TM) Client VM 11.0-b16; Sun Microsystems Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_11-b03
  Java Home               = /usr/local/java/jdk1.6.0_11/jre
  System Locale; Encoding = en_US (nb); UTF-8
Comment 1 Marian Petras 2009-01-17 21:12:01 UTC
Created attachment 75935 [details]
full thread-dump (generated by jstack)
Comment 2 Vitezslav Stejskal 2009-01-19 12:09:54 UTC
Should already be fixed - http://hg.netbeans.org/main/rev/06b409d61fca and issue #156443 and issue #155326.

*** This issue has been marked as a duplicate of 156443 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo