Bug 156885 - MaxDB JDBC driver: database connection impossible
MaxDB JDBC driver: database connection impossible
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
6.x
PC All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 13:06 UTC by kawazu428
Modified: 2010-04-01 12:24 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kawazu428 2009-01-15 13:06:54 UTC
Used to work with the MaxDB JBDC driver successfully in earlier NetBeans versions, so far I fail to do so in recent
builds: Newly added the driver, tried "Connect using...", entered my connection data (userid/password, JDBC url) and
ended up with this:

org.netbeans.api.db.explorer.DatabaseException: unable to create specification, null
        at org.netbeans.modules.db.explorer.DatabaseConnector.finishConnect(DatabaseConnector.java:146)
[catch] at
org.netbeans.modules.db.explorer.action.ConnectUsingDriverAction$NewConnectionDialogDisplayer$2.propertyChange(ConnectUsingDriverAction.java:219)
        at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
        at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:276)
        at org.netbeans.modules.db.explorer.DatabaseConnection.doConnect(DatabaseConnection.java:603)
        at org.netbeans.modules.db.explorer.DatabaseConnection.access$100(DatabaseConnection.java:98)
        at org.netbeans.modules.db.explorer.DatabaseConnection$2.run(DatabaseConnection.java:650)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)

It doesn't seem to be a general issue however, connecting to JavaDB resources works as intended. 


Product Version: NetBeans IDE Dev (Build 200901150201)
Java: 1.6.0_11; Java HotSpot(TM) Client VM 11.0-b16
System: Linux version 2.6.27-11-generic running on i386; UTF-8; de_DE (nb)
Userdir: /home/kr/.netbeans/dev-pre7
Comment 1 Rob Englander 2009-01-15 13:25:54 UTC
When you say it worked in earlier NetBeans versions, can you be more specific?  Does it
work for you in 6.5?  Did it work in 7.0 M1?  I'm trying to narrow down where this change in
behavior may have been introduced.

Thanks.
Comment 2 kawazu428 2009-01-15 13:32:35 UTC
It works as supposed using 6.5, and so far it didn't work with any of the netbeans nightly builds released the last week...
Comment 3 kawazu428 2009-01-16 09:34:07 UTC
Adding to this, this problem doesn't only affect database explorer. At the moment, using MaxDB I am unable to make use
of most of the persistence tooling (i.e. create an entity class from an existing database)...
Comment 4 Jiri Rechtacek 2009-02-10 15:23:06 UTC
Reassigned to new owner.
Comment 5 Jiri Rechtacek 2010-04-01 12:24:48 UTC
It this still problem? Recent fixes in NB6.9 should fix this. Please verify.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo