Bug 156734 - ModificationResult.FilteringReader.read doesn't return -1
ModificationResult.FilteringReader.read doesn't return -1
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P3 (vote)
: 8.0
Assigned To: Svata Dedic
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: PATCH_AVAILABLE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-14 08:02 UTC by Jiri Skrivanek
Modified: 2013-12-02 08:49 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Proposed Patch (580 bytes, patch)
2013-07-03 12:12 UTC, Jaroslav Havlin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2009-01-14 08:02:03 UTC
Submitted on behalf of external user.

Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 1.5.0_06-b05, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_06-b05
OS: Windows XP, 5.1, x86
User comments: NetBEans SUCKS
STACKTRACE: (first 10 lines)
org.openide.filesystems.FileAlreadyLockedException: E:\NetBeansProjects\ICEFacesDemo\src\java\icefacesdemo\ProviderFind.java
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.registerLock(LockForFile.java:107)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.tryLock(LockForFile.java:96)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.lock(FileObj.java:277)
        at org.openide.loaders.MultiDataObject$Entry.takeLock(MultiDataObject.java:1189)
        at org.openide.loaders.FileEntry.delete(FileEntry.java:132)
        at org.openide.loaders.MultiDataObject.handleDelete(MultiDataObject.java:524)
        at org.openide.loaders.DataObject$4.run(DataObject.java:608)
        at org.openide.loaders.DataObject$1WrapRun.run(DataObject.java:849)
        at org.openide.loaders.DataObjectPool$1WrapAtomicAction.run(DataObjectPool.java:258)
        at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
Comment 1 Peter Zavadsky 2009-01-20 19:23:17 UTC
This belongs to IceFaces.
Comment 2 Martin Janicek 2013-03-06 14:10:54 UTC
Do not think this is related to IceFaces - the same exception just jump on me and I'm not using IceFaces at all.. not sure where it belong, reassigning for evaluation
Comment 3 Jaroslav Havlin 2013-07-03 12:12:16 UTC
Created attachment 136649 [details]
Proposed Patch
Comment 4 Jaroslav Havlin 2013-07-03 12:16:12 UTC
I was able to reproduce the bug by accepting the hint that suggests transforming items in Bundle.properties to @NbBundle.Messages annotations (thank you, Martin).

It seems that the problem is caused by method
ModificationResult.FilteringReader.read(char[], int, int),
that cannot return value -1 at the end of input file.

Please check the patch and apply it if you think it is OK. Thank you.
Comment 5 Svata Dedic 2013-11-25 09:45:31 UTC
Thank you for the analysis & patch, Jardo.

Committed as rev. http://hg.netbeans.org/jet-main/rev/adec8af77fae.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo