Bug 156527 - "Portlet is temporarly unavailble" is shown when actionURL is performed with Directory Deployement enabled
"Portlet is temporarly unavailble" is shown when actionURL is performed with ...
Status: RESOLVED WONTFIX
Product: contrib
Classification: Unclassified
Component: Portalpack
6.x
Macintosh All
: P2 (vote)
: 6.x
Assigned To: Satyaranjan D
kk_sriram
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 11:42 UTC by bharani
Modified: 2009-03-17 07:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Web app (1.10 MB, application/x-tar)
2009-01-09 11:43 UTC, bharani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bharani 2009-01-09 11:42:02 UTC
Portlet is temporarly unavailble is shown when actionURL is performed with Directory Deployement enabled when try to
render a parameter with <portlet:actionURL> and <portlet:remderURL">. When the home page is clicked the render parameter
are seen. Find the trace below:



[#|2009-01-09T11:29:57.422+0000|WARNING|sun-appserver2.1|org.apache.coyote.tomca
t5.CoyoteRequest|_ThreadID=26;_ThreadName=httpSSLWorkerThread-8080-3;_RequestID=7d0f9ae5-6096-44b8-ae72-6fb9e01a9458;|PWC4011:
Unable to set request character e
ncoding to utf-8 from context , because request parameters have already been rea
d, or ServletRequest.getReader() has already been called|#]

[#|2009-01-09T11:30:02.613+0000|INFO|sun-appserver2.1|javax.enterprise.system.stream.out|_ThreadID=17;_ThreadName=httpSSLWorkerThread-8080-0;|11:30:02,612
ERROR [jsp:52] com.sun.portal.container.ContainerException: PortletContainer.executeAction():
java.lang.NullPointerException        at com.sun.portal.portletcontainer.impl.PortletContainer.executeAction(P
ortletContainer.java:389)

Note: The same scenario is not happening with Liferay 5.1.2 Tomcat bundle
Comment 1 bharani 2009-01-09 11:43:56 UTC
Created attachment 75631 [details]
Web app
Comment 2 Satyaranjan D 2009-01-13 08:33:07 UTC
Not reproducible with the current build. Changing the status to later.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo