Bug 15627 - Add "wrap to fit" property to Output Window settings
Add "wrap to fit" property to Output Window settings
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
Sun Solaris
: P3 (vote)
: 6.x
Assigned To: ivan
ivan
:
: 19824 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-19 13:34 UTC by Jiri Skrivanek
Modified: 2008-12-23 08:41 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2001-09-19 13:34:41 UTC
It would be nice to be able to set whether lines printed to the output window
are wrapped to fit the size of the window or not.
Comment 1 Jan Chalupa 2001-11-27 11:50:33 UTC
Target milestone -> 3.3.1.
Comment 2 Jan Chalupa 2001-11-27 11:53:58 UTC
Target milestone -> 3.3.1.
Comment 3 Jan Chalupa 2002-01-11 14:03:32 UTC
Target milestone -> 3.4
Comment 4 Jan Chalupa 2002-01-11 14:07:38 UTC
Target milestone -> 3.4
Comment 5 Jan Chalupa 2002-01-11 14:08:42 UTC
Target milestone -> 3.4
Comment 6 Jan Chalupa 2002-01-11 14:11:31 UTC
Target milestone -> 3.4
Comment 7 akemr 2002-02-01 15:45:55 UTC
*** Issue 19824 has been marked as a duplicate of this issue. ***
Comment 8 akemr 2002-02-06 08:35:37 UTC
Ivan,
do you think it's possible to set/unset wrapping for Term?

Thanks.
Comment 9 Marek Grummich 2002-07-22 08:38:55 UTC
Target milestone was changed from '3.4' to TBD.
Comment 10 Marek Grummich 2002-07-22 08:59:50 UTC
Target milestone was changed from '3.4' to TBD.
Comment 11 akemr 2002-08-01 12:48:12 UTC
Ivan,
do you think it's possible to set/unset wrapping for Term?
Comment 12 ivan 2002-08-02 21:32:23 UTC
There is Term.setHorizontallyScrollable() which if set to false
will enable line wrapping. 

Note that lines don't get re-wrapped on a resize and as you
toggle back and forth between wrapping and no wrapping.
Comment 13 _ tboudreau 2004-08-16 02:47:31 UTC
This is fixed as far as the new output window is concerned; Ivan, if 
you wanted to borrow some of the goodies for Term, it might not be 
too hard (actually the entire storage/line wrap mechanism is pretty 
portable - might move a few of the wrap-related methods from 
OutputDocument into OutputWriter, but it wouldn't be much work - I'd 
like to put the wrapping related stuff into its own class anyway).

Who knew - like, convergence...interested?
Comment 14 Jiri Skrivanek 2004-12-02 12:36:43 UTC
As Tim wrote it is fixed in NetBeans4.0.
Comment 15 Jiri Skrivanek 2004-12-02 12:37:08 UTC
Verified.
Comment 16 Quality Engineering 2008-12-23 08:41:41 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo