Bug 155938 - ClassCastException: org.netbeans.modules.db.mysql.DatabaseUser
ClassCastException: org.netbeans.modules.db.mysql.DatabaseUser
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 14:34 UTC by Roman Mostyka
Modified: 2009-10-05 11:21 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.88 KB, text/plain)
2008-12-22 14:35 UTC, Roman Mostyka
Details
stacktrace (6.08 KB, text/plain)
2009-08-05 15:00 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-12-22 14:34:34 UTC
Build: NetBeans IDE Dev (Build 081222)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-132, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-275
OS: Mac OS X, 10.4.11, i386

User Comments:
romanmostyka: 1. Register MySQL server.
2. Rightclick server's node and choose "Create Database".
3. Check "Grant Full Access To:" checkbox and choose one of suggested values.
4. Choose one of the sample data.

Result: ClassCastException arises.

romanmostyka: 1. Register MySQL server.
2. Rightclick server's node and choose "Create Database".
3. Check "Grant Full Access To:" checkbox and choose one of suggested values.
4. Choose one of the sample data.

Result: ClassCastException arises.



Stacktrace: 
java.lang.ClassCastException: org.netbeans.modules.db.mysql.DatabaseUser
        at org.netbeans.modules.db.mysql.ui.CreateDatabasePanel.validatePanel(CreateDatabasePanel.java:75)
        at org.netbeans.modules.db.mysql.ui.CreateDatabasePanel.comboDatabaseNameItemStateChanged(CreateDatabasePanel.java:505)
        at org.netbeans.modules.db.mysql.ui.CreateDatabasePanel.access$1500(CreateDatabasePanel.java:47)
        at org.netbeans.modules.db.mysql.ui.CreateDatabasePanel$5.itemStateChanged(CreateDatabasePanel.java:443)
        at javax.swing.JComboBox.fireItemStateChanged(JComboBox.java:1162)
        at javax.swing.JComboBox.selectedItemChanged(JComboBox.java:1219)
Comment 1 Roman Mostyka 2008-12-22 14:35:30 UTC
Created attachment 75245 [details]
stacktrace
Comment 2 Jiri Rechtacek 2009-02-10 15:22:15 UTC
Reassigned to new owner.
Comment 3 Jiri Rechtacek 2009-07-01 07:44:01 UTC
NB6.7 was released already - http://www.netbeans.org/community/releases/67/
Postpone fixing this issue on the next release.
Comment 4 Exceptions Reporter 2009-08-05 15:00:22 UTC
Build: NetBeans IDE 6.5 (Build 090407)
VM: OpenJDK Client VM, 14.0-b08, OpenJDK Runtime Environment, 1.6.0_0-b14
OS: Linux, 2.6.28.10-mw1, i386

User Comments: 
create sample databse travel with grant to duke@*

Stacktrace: 
java.lang.ClassCastException: org.netbeans.modules.db.mysql.DatabaseUser cannot be cast to java.lang.String
        at org.netbeans.modules.db.mysql.ui.CreateDatabasePanel.validatePanel(CreateDatabasePanel.java:75)
        at org.netbeans.modules.db.mysql.ui.CreateDatabasePanel.comboDatabaseNameItemStateChanged(CreateDatabasePanel.java:505)
        at org.netbeans.modules.db.mysql.ui.CreateDatabasePanel.access$1500(CreateDatabasePanel.java:47)
        at org.netbeans.modules.db.mysql.ui.CreateDatabasePanel$5.itemStateChanged(CreateDatabasePanel.java:443)
        at javax.swing.JComboBox.fireItemStateChanged(JComboBox.java:1224)
        at javax.swing.JComboBox.selectedItemChanged(JComboBox.java:1281)
Comment 5 Exceptions Reporter 2009-08-05 15:00:28 UTC
Created attachment 85847 [details]
stacktrace
Comment 6 Exceptions Reporter 2009-08-05 15:00:34 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=144262
Comment 7 Jiri Rechtacek 2009-10-05 11:21:08 UTC
It's not reproducible in the recent build. No other report since NB6.7 FCS. Seems be working correctly.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo