Bug 155786 - Auto-connect from SQL Editor blocks IDE while waiting for connection to complete
Auto-connect from SQL Editor blocks IDE while waiting for connection to complete
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
fix-in-68
:
: 156528 164591 167330 167542 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 18:44 UTC by David Vancouvering
Modified: 2009-07-25 06:22 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Full Thread Dump while frozen IDE with broken network (24.31 KB, text/plain)
2009-06-23 15:30 UTC, Jiri Rechtacek
Details
Full thread dump while broken network connection (58.30 KB, text/plain)
2009-06-30 13:51 UTC, Jiri Rechtacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Vancouvering 2008-12-18 18:44:41 UTC
- Connect to a MySQL database
- Select a table and do "Show Data"
- Stop the database server
- Re-start NB
- Go to the SQL console window
- Select the same connection, now disconnected
- Run the command

Note that while we are trying to connect to the (down) server, the *entire* IDE is locked up.  I think this is the
Database Explorer connect API causing this, but need to investigate.
Comment 1 Jiri Rechtacek 2009-02-10 15:16:16 UTC
Reassigned to new owner.
Comment 2 Jiri Rechtacek 2009-02-24 13:41:34 UTC
*** Issue 156528 has been marked as a duplicate of this issue. ***
Comment 3 Jiri Rechtacek 2009-05-12 16:52:53 UTC
*** Issue 164591 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Rechtacek 2009-06-22 19:16:21 UTC
*** Issue 167330 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Rechtacek 2009-06-23 15:30:20 UTC
Created attachment 83940 [details]
Full Thread Dump while frozen IDE with broken network
Comment 6 Jiri Rechtacek 2009-06-23 15:58:49 UTC
*** Issue 167542 has been marked as a duplicate of this issue. ***
Comment 7 Jiri Rechtacek 2009-06-23 15:59:03 UTC
*** Issue 167542 has been marked as a duplicate of this issue. ***
Comment 8 Jiri Rechtacek 2009-06-30 13:51:11 UTC
Created attachment 84185 [details]
Full thread dump while broken network connection
Comment 9 Quality Engineering 2009-07-03 17:37:26 UTC
Integrated into 'main-golden', will be available in build *200907031400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e4df18ecea4c
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #155786: SQL Editor blocks IDE while waiting for connection to complete (it's not a final fix yet!)
Comment 10 Jiri Rechtacek 2009-07-24 13:10:51 UTC
I guess most of problems should be fixed now. Please file new issue for a particular problems, if any. Thanks
core-main/rev/33ab9ed49a09
Comment 11 Quality Engineering 2009-07-25 06:22:38 UTC
Integrated into 'main-golden', will be available in build *200907250201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/33ab9ed49a09
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #155786: Auto-connect from SQL Editor blocks IDE while waiting for connection to complete


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo