Bug 155452 - NullPointerException at org.netbeans.modules.python.api.PythonPlatformManager.findPlatformProperties
NullPointerException at org.netbeans.modules.python.api.PythonPlatformManager...
Status: RESOLVED FIXED
Product: python
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: TBD
Assigned To: ardavis26
nbpythonqa
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 09:57 UTC by rmatous
Modified: 2009-04-23 05:01 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.71 KB, text/plain)
2008-12-15 09:57 UTC, rmatous
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rmatous 2008-12-15 09:57:09 UTC
Build: NetBeans IDE Dev (Build 081209)
VM: Java HotSpot(TM) Client VM, 1.5.0_13-b05, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_13-b05
OS: Linux, 2.6.22-14-generic, i386

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.python.api.PythonPlatformManager.findPlatformProperties(PythonPlatformManager.java:375)
        at org.netbeans.modules.python.platform.panels.PythonPlatformPanel.newPlatformActionPerformed(PythonPlatformPanel.java:454)
        at org.netbeans.modules.python.platform.panels.PythonPlatformPanel.access$300(PythonPlatformPanel.java:38)
        at org.netbeans.modules.python.platform.panels.PythonPlatformPanel$3.actionPerformed(PythonPlatformPanel.java:141)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2169)
Comment 1 rmatous 2008-12-15 09:57:13 UTC
Created attachment 74947 [details]
stacktrace
Comment 2 ardavis26 2008-12-15 12:54:51 UTC
Can you give me a detailed description of what you were doing when you got the error?
Comment 3 rmatous 2008-12-15 13:04:31 UTC
Somethink like ProjectProperties->Category Python->add new platform. 

Cannot reproduce because now I get exc. whenever I select Category Python in project properties:
java.lang.NullPointerException
	at java.text.CollationElementIterator.<init>(CollationElementIterator.java:102)
	at java.text.RuleBasedCollator.getCollationElementIterator(RuleBasedCollator.java:356)
	at java.text.RuleBasedCollator.compare(RuleBasedCollator.java:399)
	at
org.netbeans.modules.python.api.PlatformComponentFactory$PythonPlatformListModel$1.compare(PlatformComponentFactory.java:222)
Comment 4 Exceptions Reporter 2008-12-19 14:42:53 UTC
This issue has already 150 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=110683
Comment 5 ardavis26 2009-04-23 05:01:06 UTC
Fixed NPE 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo