Bug 155186 - A project using a webservice always shows errors and makes JSF designer unusable.
A project using a webservice always shows errors and makes JSF designer unusa...
Status: RESOLVED FIXED
Product: webservices
Classification: Unclassified
Component: JAX-WS
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
:
Depends on: 105645
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 21:37 UTC by ddevore
Modified: 2009-02-19 23:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ddevore 2008-12-10 21:37:51 UTC
A project that uses a webservice from another project always shows errors, in 6.1 if you recompiled or refreshed the ws
client the errors would not be reported anymore. The errors are that the classes of the generated ws client don't exist
thought the project will compile and run correctly. This error also causes the JSF designer to be completely useless.
Comment 1 Milan Kuchtiak 2008-12-11 09:41:55 UTC
Right, the issue is easily reproducible.
The workaround is to open properties dialog, change something (e.g. add some library) and close.

Looking for fix. 
Comment 2 Milan Kuchtiak 2008-12-11 14:28:13 UTC
I found that classpath of the project issn't refreshed after child project is build.

This is a similar (simpler) scenario :
- create a WS client in J2SEApplication project
- use generated classes in Main.java
- clean project
- restart IDE
- generated classes are error badged in Main.java. Project's build doesn't help.

The workaround is to build project, open Properties dialog and close it (no changes are needed in Properties dialog).
In case of two projects, the Properties dialog should be open in project where WS Client is generated.

We need to wait until some support for generated sources is implemented. Se the issue 105645.
Comment 3 ddevore 2008-12-11 15:53:54 UTC
This worked in 6.1 so I am guessing that this would be considered a defect, as it is currently marked. The problem I
have with this is that it has been marked as being dependent on an enhancement. How can a defect be dependent on an
enhancement. Also, why would a bug such as this, where it makes the designer unusable, be targeted for 7.0.
Comment 4 Milan Kuchtiak 2009-02-04 16:57:32 UTC
Fixed. Regarding CC, the generated sources are now handled as normal sources.
See the issue 105645.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo