Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 155173 - Advanced cell editor for certain number of variants
Advanced cell editor for certain number of variants
Status: RESOLVED DUPLICATE of bug 155721
Product: db
Classification: Unclassified
Component: Show Data
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 18:00 UTC by Roman Mostyka
Modified: 2012-07-10 17:46 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Screenshot of advanced data editor. (48.53 KB, image/png)
2008-12-11 09:24 UTC, Roman Mostyka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-12-10 18:00:56 UTC
Advanced cell editor for data, which can be chosen only from certain number of variants. We can invoke drop down list to
simplify variants choosing. Like we do now with large text.
Comment 1 _ ahimanikya 2008-12-10 20:31:36 UTC
I am not sure I understand what we should populate in the drop down. If the number Integer, you want the tool to provide
a drop down from Integer.Min to Integer.Max? I guess its much easier to type a number.

We should only do this only if the variants that you are talking will make it easier for user to enter a number value,
please provide any pointer if available. 
Comment 2 Roman Mostyka 2008-12-11 09:23:49 UTC
No, not for standard types.
I saw this in the our competitor tool. You can see what I mean on a screenshot.
Comment 3 Roman Mostyka 2008-12-11 09:24:43 UTC
Created attachment 74839 [details]
Screenshot of advanced data editor.
Comment 4 _ ahimanikya 2008-12-11 10:00:05 UTC
OK. This looks like for for reference columns generated from the FK, I guess.

Thanks for looking into all the possible enhancement. 
Comment 5 Jiri Rechtacek 2009-10-16 14:06:12 UTC
Reassigned to new owner.
Comment 6 matthias42 2012-07-10 17:46:36 UTC

*** This bug has been marked as a duplicate of bug 155721 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo