Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 155087 - Surround statement and block with try-catch hint should allow template customization
Surround statement and block with try-catch hint should allow template custom...
Status: RESOLVED DUPLICATE of bug 116818
Product: java
Classification: Unclassified
Component: Hints
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: Max Sauer
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 01:08 UTC by _ wadechandler
Modified: 2009-02-19 21:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ wadechandler 2008-12-10 01:08:12 UTC
Surround with try-catch should allow a user to enter a template just like in code templates which can be used to setup
their catch statements to match whatever libraries they may be using. A user on nbusers brought this up, and they would
wish to use LogFactory. Too, it is possible some others would want to use other APIs. This sounded like a good idea, so
I filed an issue for them.

I believe the current options should still be available as check boxes such as:

_ Use o.o.u.Exceptions.printStrackTrace
_ Use j.u.l.Logger
_ Use Exception.printStackTrace (though this one needs to really be able to be turned off...isn't able now)
_ Use custom template

and that would fix the issue.
Comment 1 Jan Lahoda 2008-12-10 10:50:34 UTC
See issue #116818.

*** This issue has been marked as a duplicate of 116818 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo