Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 155030 - Web service references in existing Java SE project are not displayed
Web service references in existing Java SE project are not displayed
Status: RESOLVED FIXED
Product: webservices
Classification: Unclassified
Component: Code
6.x
All All
: P3 with 1 vote (vote)
: 7.0
Assigned To: Milan Kuchtiak
issues@webservices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 14:38 UTC by Petr Jiricka
Modified: 2013-08-27 12:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2008-12-09 14:38:21 UTC
Build #53 of the ergonomics clone.

1. Create a Java SE project
2. Create a WSDL file in this project
3. Create a web service client from this WSDL file (choose "Local File" option in the wizard)
=> Web Service References node will be displayed in the logical view
4. Shut down the IDE and start it with a fresh user dir (this simulates passing the project to another user)
5. Open the Java SE project that was created previously
=> Web Service References node is missing
Comment 1 Jaroslav Tulach 2008-12-17 14:19:55 UTC
It seems to me that the same problem can be reproduced with plain Java SE IDE. 

0a. download Java SE IDE (the smallest Java IDE)
0b. make sure install dir of the IDE is read only
0c. use Tools/Plugins/Available and install Web Services - restart.
1. Create a Java SE project
2. Create a WSDL file in this project
3. Create a web service client from this WSDL file (choose "Local File" option in the wizard)
=> Web Service References node will be displayed in the logical view
4. Shut down the IDE and start it with a fresh user dir (this simulates passing the project to another user)
5. Open the Java SE project that was created previously
=> Web Service References node is missing

I'll pass this issue to web services maitainers for evaluation. This seems to be the behaviour which we have for ages, 
so I am not sure what they will think about the report. However if we are supposed to fix it in general way, then I'd 
advocate the project metadata to hold the list of modules that are required/suggested to be enabled in order to 
manipulate the project. 
Comment 2 Milan Kuchtiak 2009-01-05 13:39:47 UTC
Reporter (pjiricka), please confirm whether this is the same problem mentioned by jtulach ?
I cannot reproduce this issue with enterprise (cluster) configuration.

Note: web services support doesn't save any data to user dir.
Comment 3 Jaroslav Tulach 2009-01-05 14:36:19 UTC
To reproduce the problem it is better to start with Java SE. Following steps are guaranteed to reproduce the problem:

0a. download Java SE IDE (the smallest Java IDE)
0b. make sure install dir of the IDE is read only
0c. use Tools/Plugins/Available and install Web Services - restart.
1. Create a Java SE project
2. Create a WSDL file in this project
3. Create a web service client from this WSDL file (choose "Local File" option in the wizard)
=> Web Service References node will be displayed in the logical view
4. Shut down the IDE and start it with a fresh user dir (this simulates passing the project to another user)
5. Open the Java SE project that was created previously
=> Web Service References node is missing

Comment 4 Petr Jiricka 2009-01-23 16:57:32 UTC
You are right that this problem is reproducible also with Java SE IDE, and technically existed also in NB 6.5. However,
in this scenario is is really easy for the user to figure out what the problem is - if I have a different set of plugins
than my coworkers (or than I had when creating the project), I can not expect things to work the same way. And the
remedy is obvious - just install the missing modules. 
In the original scenario I reported, the remedy is very non-obvious: both users downloaded the same bits, and they are
seeing different results, and it is not clear why. This is a much more serious problem than what you describe. So before
the "ergonomics" changes, this was a P4 problem, now it is a P2.

I think the fix should be to make it much more obvious to the user that some features are disabled, and make it very
easy to enable them - or even force the user to make the choice about which features to enable.
See also the UI spec: http://wiki.netbeans.org/FitnessForeverUISpec. This is an analogous case to issue 155032.
Comment 5 Jaroslav Tulach 2009-01-24 09:16:08 UTC
I do not think the original problem is unimportant. I see it as significant usability flaw. We detect and report that 
a library is missing, I see no reason why we shall not report that an important IDE functionality is missing too.

Anyway, ergonomics now enable enterprise cluster in case there is webservices extension in the project: 
ergonomics#d8606e21bb10

Lowering to P3 and leaving open in a hope that missing extension support will be reported for users of Java SE 
edition.
Comment 6 skalynuk 2009-05-06 21:58:26 UTC
This problem also appears with a new Enterprise Application Client project.
1. Create a new Enterprise Application Client
2. Select New->Web Service Client...
3. Select Local File and browse to a local .wsdl file
4. Select Finish
The Web Service References node does not appear in the Projects view.

However, following the same procedure, but with a new Java Application project, the Web Service References node does appear.
Comment 7 Milan Kuchtiak 2013-08-27 12:34:17 UTC
The original issue with SOAP client, and ergonomics scenario, described by J.Tulach, is likely fixed.
(tested the scenario and don't see any issue) 

Seems to be fixed by implementing J2seJaxWsOpenHook.
See:
http://hg.netbeans.org/web-main/rev/165639

See also bug 177644.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo