Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 154800 - Cannot Add Server JBoss 5.0.0 GA
Cannot Add Server JBoss 5.0.0 GA
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: JBoss
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Thuy.d Nguyen
issues@serverplugins
65fixes2-verified
:
: 155101 155737 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 19:32 UTC by atehrani
Modified: 2009-02-19 23:04 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot (33.83 KB, image/jpeg)
2008-12-05 19:33 UTC, atehrani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description atehrani 2008-12-05 19:32:44 UTC
JBoss 5.0.0 GA (final) was recently released and when attempting to add the server to Netbeans 6.5 it does not appear to
read the domain paths. I am stuck at that part of the Add Server Wizard and unable to continue.

See screenshot.
Comment 1 atehrani 2008-12-05 19:33:34 UTC
Created attachment 74630 [details]
Screenshot
Comment 2 Petr Hejl 2008-12-08 11:46:53 UTC
Layout of jar files is changed.
See JBPluginUtils.getDomainRequirements5x() and JBPluginUtils.getDomainAlterRequirements5x().
Comment 3 Petr Blaha 2008-12-08 11:56:49 UTC
Petre, this would be simple fix and we should fix the problem. Also, the fix would be included in NB 6.5 Patch2 since we
can expect people will switch on the JBoss 5.0 FCS in upcoming months.
Comment 4 Petr Blaha 2008-12-10 09:51:01 UTC
*** Issue 155101 has been marked as a duplicate of this issue. ***
Comment 5 Petr Blaha 2008-12-10 09:52:16 UTC
Increasing the priority to P2 since the issue was several time discussed on mailing lists.
Comment 6 Thuy.d Nguyen 2008-12-17 23:27:07 UTC
Refactored the code to be able to add/start/stop JBoss 5.0.0 GA from within the IDE.

However, one will see the below INFO message in the log file when accessing JBoss server from the Servers node (on
Service tab). I could not figure out how to turn off these messages programmatically since we do not own JBoss code.

To turn off the message manually, you can add -J-Dorg.netbeans.ProxyClassLoader.level=10000 option when running Netbeans
IDE.

----------------
INFO [org.netbeans.ProxyClassLoader] java.lang.IllegalStateException: You are trying to access file: log4j.properties
from the default package. Please see
http://www.netbeans.org/download/dev/javadoc/org-openide-modules/org/openide/modules/doc-files/classpath.html#default_package
        at org.netbeans.ProxyClassLoader.printDefaultPackageWarning(ProxyClassLoader.java:555)
        at org.netbeans.ProxyClassLoader.getResource(ProxyClassLoader.java:323)
        at java.lang.ClassLoader.getResource(ClassLoader.java:972)
        at org.apache.log4j.helpers.Loader.getResource(Loader.java:96)
        at org.apache.log4j.LogManager.<clinit>(LogManager.java:105)
......
        
Comment 7 Thuy.d Nguyen 2008-12-17 23:34:11 UTC
Chnageset of the fix: http://hg.netbeans.org/main/rev/755ab2441358
Comment 8 Petr Hejl 2008-12-18 09:17:43 UTC
*** Issue 155737 has been marked as a duplicate of this issue. ***
Comment 9 Petr Blaha 2008-12-18 10:04:22 UTC
verified in NetBeans IDE Dev (Build 081218)
Comment 10 pslechta 2008-12-18 15:42:33 UTC
The fix was ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/ffe926854f2a
Comment 11 Quality Engineering 2008-12-22 15:11:41 UTC
Integrated into 'main-golden', will be available in build *200812221122* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/755ab2441358
User: thuydn@netbeans.org
Log: #154800 : Refactored the code to be able to add/start/stop JBoss 5.0 from within the IDE.
Comment 12 patriziocannoni 2009-01-08 13:16:28 UTC
When will new module be available in Netbeans 6.5 Update Center?
Comment 13 pslechta 2009-01-08 13:43:45 UTC
The fix is part of 6.5 patch 2, so if everything goes well, is should be available on Update Center around January 29th.
Comment 14 pgebauer 2009-01-08 13:44:11 UTC
Please, check "Plan for 6.5 Patch2" at http://wiki.netbeans.org/NetBeansPatchesInfo
Comment 15 Martin Fousek 2009-01-19 13:01:15 UTC
Verified for patch2.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo