Bug 154089 - Endless loading in Editor
Endless loading in Editor
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Text
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: mslama
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 13:04 UTC by expendo
Modified: 2008-12-22 11:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
endless loading... (118.41 KB, image/jpeg)
2008-11-28 13:05 UTC, expendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description expendo 2008-11-28 13:04:50 UTC
Hi there.

I dont't know what i've done but i got a endless loading screen on the editor.
screenshot: http://virus-2k.info/netbeans.jpg

i've already reinstalled netbeans but it still doesn't work.
regardless which file i try to open. i always got this silly loading forever message.... (or should i wait more then 30
minutes?)

the navigator seems to load correct... 

please help me :(
... or how can i uninstall netbeans completly to reset all settings?
Comment 1 expendo 2008-11-28 13:05:34 UTC
Created attachment 74271 [details]
endless loading...
Comment 2 Jiri Prox 2008-11-28 14:03:15 UTC
Please capture several threaddumps while file is being opened and attach it here
http://wiki.netbeans.org/GenerateThreadDump

Does it happen only for php files or for all types (java,xml ... )?

To uninstall NB completely - remove install dir and your userdir (located in your home directory in folder .netbeans)

Thanks
Comment 3 expendo 2008-11-28 14:34:56 UTC
It happens with all files. (txt, xml, html, etc)

I try to reinstall it completly.
Comment 4 expendo 2008-11-28 15:54:25 UTC
After reinstall (and deleting the files located in user-dir) it worked again.

You don't know how this could be happend do you? :/
Comment 5 Vitezslav Stejskal 2008-12-01 10:26:04 UTC
The editor loading is done in openide/text. But I am afraid that without a stacktrace (full thread dump) we won't be
able to diagnose this. Do you have the userdir where the problem was reproducible? If it happens again please try to
generate full thread dump (http://wiki.netbeans.org/GenerateThreadDump) and attach it here. Thanks
Comment 6 Lukas Hasik 2008-12-01 11:23:39 UTC
I'm closing as worksforme. There is nothing that we can do now. To be able to fix it we need the thread dump(as
requested in previous comment). 
If it will happen again don't turn off the IDE but take the thread dump. Attach it here and reopen the issue.

thank you for report


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo