Bug 15373 - It is impossible to remove CookieSet.Factory from CookieSet.
It is impossible to remove CookieSet.Factory from CookieSet.
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Nodes
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: David Strupl
issues@platform
: API
: 11770 (view as bug list)
Depends on:
Blocks: 19724
  Show dependency treegraph
 
Reported: 2001-09-11 16:34 UTC by _ lkramolis
Modified: 2008-12-22 20:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ lkramolis 2001-09-11 16:34:51 UTC
I tried to remove CookieSet.Factory from CookieSet, but it is impossible be
cause the factory is not in cookieSet's map. Cookie created by factory has
different class than factory was registered. It is impossible to specify, which
item could be removed from cookiesSet's map.
Methods like

    void remove (Class[] cookieClass, CookieSet.Factory factory);    void remove
(Class   cookieClass, CookieSet.Factory factory);

could help to resolve this problem.
Comment 1 David Strupl 2001-09-12 16:04:18 UTC
Why is this request for API enhancement marked as defect? Changing to
enhancement.
Comment 2 _ lkramolis 2001-09-12 16:27:12 UTC
It is *not* RFE. It *is* bug report. I need to remove factory from
CookieSet. I do not want to change API.

I just propose clear solution with new methods, but if you fix it
without API change, I will be happy too. I do not need new API, I need
to remove factory from set.

Reverted to DEFECT.
Comment 3 David Strupl 2001-09-12 16:40:16 UTC
As you wish. Please watch the discussion on nbdev. Adding
public/protected methods to openide classes *is* API change. If the
fix cannot be done without API change, we either have to change the
API or leave your bug report not fixed. Sorry.
Comment 4 David Strupl 2001-09-17 12:52:15 UTC
After watching the discussion on nbdev I am changing this to
enhancement again. I completely agree with Jesse here.
Comment 5 Jan Chalupa 2001-11-27 13:03:01 UTC
Target milestone -> 3.3.1.
Comment 6 David Strupl 2002-01-30 12:38:27 UTC
*** Issue 11770 has been marked as a duplicate of this issue. ***
Comment 7 David Strupl 2002-02-28 15:13:27 UTC
Fixed in trunk. Openide version 2.6.
CookieSet 1.13.
Comment 8 Jaroslav Tulach 2002-02-28 15:30:17 UTC
I can tell from my experience that the CookieSet code is easy to be
broken and hard to define how exactly it should work.

Please cover the behaviour of new methods by tests.

Reopened, as P3 defect.
Comment 9 David Strupl 2002-03-07 13:55:32 UTC
Fixed in CookieSetTest 1.4.
Comment 10 pzajac 2003-07-31 10:51:45 UTC
verified, the test seems fine.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo