Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 153670 - Highlighting for curved-bracket "( )" for xml documents is not working in NetBeans 6.5
Highlighting for curved-bracket "( )" for xml documents is not working in Net...
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Text-Edit
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Samaresh Panda
issues@xml
65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 20:47 UTC by romanm
Modified: 2009-02-19 23:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description romanm 2008-11-21 20:47:25 UTC
Highlighting for curved-bracket "( )" for xml documents is not working in NetBeans 6.5 .
It is working in NetBeans 6.1.

This is an example of use the feature:
In NetBens 6.1 I could easy track the parenthesis because the highlighting was working for curved-bracket *( )* .

<item1>
  <name>Formula1</name>
<formula>((!165<2)*($10-1.125-(H=1)*.1875*(!1=4)-((!902=1)*.125*(H=1)*(!1=4))-(H=0)*.250*(!1=4))
+\(!165=2)*($10(H=1)*(!1=4)*((!105<10)*1.6875+(!105>10)*(!105<12)*1.8125+(!105>12)*1.75)-(H=0)*(!1=4)*((!105<10)*1.75+(!105>10)*1.5)))*($10>0)</formula>
</item1>

Thanks,
Roman
Comment 1 Samaresh Panda 2009-01-09 19:17:15 UTC
First integration: http://hg.netbeans.org/main/rev/1b6b0fe452ee. Surprisingly this didn't fix the issue. I'll follow up.
Please stay tuned.
Comment 2 Quality Engineering 2009-01-11 06:33:10 UTC
Integrated into 'main-golden', will be available in build *200901110304* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1b6b0fe452ee
User: samaresh@netbeans.org
Log: #153670 : Brace matching regression in XML
Comment 3 Samaresh Panda 2009-01-12 16:29:00 UTC
Fixed: http://hg.netbeans.org/main/rev/48ea653b214c.
Comment 4 tonybeckham 2009-01-13 18:36:16 UTC
Verified in trunk

Product Version: NetBeans IDE Dev (Build 20090113163951)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.5 running on i386; MacRoman; en_US (nb)
Comment 5 Samaresh Panda 2009-01-13 20:53:27 UTC
Updated with status whiteboard.
Comment 6 Quality Engineering 2009-01-14 07:44:45 UTC
Integrated into 'main-golden', will be available in build *200901140201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/48ea653b214c
User: samaresh@netbeans.org
Log: #153670 : call default matcher as a fall through.
Comment 7 Samaresh Panda 2009-01-14 14:56:19 UTC
The fix will be available as a patch(2). See patch2 plan http://wiki.netbeans.org/NetBeans65Patch2Plan.
Comment 8 rbalada 2009-01-15 13:31:45 UTC
Samaresh&Tony,

was the latest fix re-verified in trunk build? Is the latest fix safe enough to apply in high-resistance fixes branch?
Comment 9 Samaresh Panda 2009-01-15 13:58:48 UTC
It was verified with 20090113163951. Tony can confirm whether or not the fix was verified in latest trunk build. Ans
yes, it is very safe to apply the fix in high-resistant branch.
Comment 10 rbalada 2009-01-15 16:02:05 UTC
The latest added changeset has not been re-verified for Patch2, thus moving to Patch3.
Comment 11 tonybeckham 2009-01-15 17:39:43 UTC
Yes, it was verified in trunk build 20090113163951, and now in latest Build 200901150201.  There was discussion of the
safety of this change in email before the change was even made...and it was determined that this was very low risk.  Do
we need to include these in evaluations as comments on the issue to get fixes into patches?
It would be a shame to see this not be in patch 2 b/c it was verified in trunk before the cutoff.
Comment 12 Samaresh Panda 2009-01-15 17:54:57 UTC
I agree, it'll be a shame if this didn't make to patch2. We still have time to re-verify it in patch2. I'm not sure why
it was pushed to patch3.
Comment 13 pgebauer 2009-01-15 21:29:04 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/f052257ae57b
Comment 14 tonybeckham 2009-01-15 21:40:55 UTC
It was moved to patch 3 because of the extra change set that was added after the fix was verified.  (see desc 7).
Comment 15 pgebauer 2009-01-22 08:48:34 UTC
Verified in 65patch2.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo