Bug 153567 - NullPointerException at org.netbeans.modules.cnd.modelimpl.csm.NamespaceImpl.findUidsByPrefix
NullPointerException at org.netbeans.modules.cnd.modelimpl.csm.NamespaceImpl....
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All All
: P1 with 1 vote (vote)
: 6.x
Assigned To: Vladimir Voskresensky
issues@cnd
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 65fixes3-fixed
:
: 153566 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 17:24 UTC by geldouches
Modified: 2009-03-16 16:32 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.26 KB, text/plain)
2008-11-20 17:25 UTC, geldouches
Details

Note You need to log in before you can comment on or make changes to this bug.
Description geldouches 2008-11-20 17:24:55 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Linux, 2.6.9-67.0.15.EL.cernsmp, i386

User Comments:
GUEST: I was changing the name of the include file from stdint.h to sys/types

GUEST: I just opened a small C-file I am going to implement:

#include "binarytree.h"


struct item {
    int value;
    struct item* left;
    struct item* right;
};

void tree_insert(struct item** root, struct item* item) {
    if (*root == NULL) {
        *root = item;
    }
}

int main(int argc, char**argv)
{

}



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.cnd.modelimpl.csm.NamespaceImpl.findUidsByPrefix(NamespaceImpl.java:250)
        at org.netbeans.modules.cnd.modelimpl.impl.services.SelectImpl.analyzeFilter(SelectImpl.java:175)
        at org.netbeans.modules.cnd.modelimpl.impl.services.SelectImpl.getDeclarations(SelectImpl.java:119)
        at org.netbeans.modules.cnd.api.model.services.CsmSelect$Default.getDeclarations(CsmSelect.java:157)
        at org.netbeans.modules.cnd.completion.csm.CsmProjectContentResolver.filterDeclarations(CsmProjectContentResolver.java:1224)
        at org.netbeans.modules.cnd.completion.csm.CsmProjectContentResolver.getNamespaceMembers(CsmProjectContentResolver.java:1194)
Comment 1 geldouches 2008-11-20 17:25:07 UTC
Created attachment 73965 [details]
stacktrace
Comment 2 Vladimir Voskresensky 2008-11-20 17:43:02 UTC
*** Issue 153566 has been marked as a duplicate of this issue. ***
Comment 3 Vladimir Voskresensky 2008-11-20 17:46:00 UTC
seems problem on getting declaration container.
will add recovery for getDeclarationsSorage() returning 'null'
Comment 4 Vladimir Voskresensky 2008-11-21 12:32:01 UTC
fixed
http://hg.netbeans.org/main?cmd=changeset;node=254a08a76aff
Comment 5 Vladimir Voskresensky 2008-11-21 13:39:30 UTC
correct commit is
http://hg.netbeans.org/main?cmd=changeset;node=46525fbb9645
Comment 6 Quality Engineering 2008-11-23 17:02:52 UTC
Integrated into 'main-golden', will be available in build *200811231401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/46525fbb9645
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixed IZ#153567: NullPointerException at org.netbeans.modules.cnd.modelimpl.csm.NamespaceImpl.findUidsByPrefix
- recover in case of broken storage
Comment 7 fenris_uy 2009-01-26 16:28:26 UTC
Should be backported to 6.5 tree in order to fix the issue to current users. 
Comment 8 Alexander Pepin 2009-02-02 13:20:56 UTC
To be backported into 6.5 branch the issue should be fixed and verified in trunk. It's need not to reopen the issue for
this purpose.
Comment 9 arne_adams 2009-02-04 10:28:02 UTC
Netbeans IDE states no updates available but the error still shows
Comment 10 Leonid Lenyashin 2009-02-04 14:25:06 UTC
Has it been fixed in 7.0? If so, then please put NO70 keyword here
Comment 11 Alexander Pepin 2009-02-05 11:18:59 UTC
This issue is nominated to be included into patch3 for NB6.5. Unfortunately for now we don't know the exact date of
patch3 release. Please do not reopen the issue unless it's reproducible in NetBeans 7.0 (trunk).
Comment 12 Alexander Pepin 2009-02-26 16:49:04 UTC
verified in build 200902260201
Comment 13 Egor Ushakov 2009-02-28 11:39:52 UTC
integrated into release65_fixes with:
http://hg.netbeans.org/release65_fixes/rev/3f30d084d1a3


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo