Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 153473 - Can not always attach if Build Result is a relative path
Can not always attach if Build Result is a relative path
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
All All
: P2 (vote)
: 6.x
Assigned To: _ gordonp
issues@cnd
65fixes2-verified
:
Depends on:
Blocks: 159063
  Show dependency treegraph
 
Reported: 2008-11-19 17:48 UTC by _ gordonp
Modified: 2009-06-25 10:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gordonp 2008-11-19 17:48:16 UTC
I have a vim71_1 project in ~/NetBeansProjects. The source files are in /usr/local/src/vim71. If I set
Build Result to a non-absolute path then I cannot attach to a running process.

This is because the current implementation prepends the runDirectory if the Build Result is relative.
It then checks if the resulting path is an executable or shared library. If not, the attach fails. It
also doesn't check if Build Result is set (I think it does on Run or Debug).

The fix should do several things: First off, if Build Result (BR) is empty then we should get similar
behavior during attach as we get during Run or Debug. Next, we should look for the exe/so of a relative
BR from the source root or possibly look repeatedly with source root just being one place.
Comment 1 _ gordonp 2008-12-04 15:30:32 UTC
Fixed in http://hg.netbeans.org/main?cmd=changeset;node=e91345591cb6
Comment 2 ahot 2008-12-22 18:14:12 UTC
- create arguments project
- Set project Properties/Build/Linker/Output to "../arguments_1"
- Run project
Result: OK 
- Debug project
Result: 
Error message appears: C:\...\Arguments_1 does not exists or is not an executable
----
Product Version: NetBeans IDE Dev (Build 200812181401)
Java: 1.6.0_07; Java HotSpot(TM) Client VM 10.0-b23
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)
Comment 3 _ gordonp 2008-12-23 18:56:19 UTC
I tested on Solaris with both an existing and fresh Arguments project and had
no such problem. Next, I tested both existing and fresh Arguments projects on
Vista and had Run fail with the following message in the output window:

    /cygdrive/c/nbdev/nbbuild/netbeans/cnd2/bin/dorun.sh: line 103: \
        ./..\arguments_1: is a directory.

I had a similar failure with Debug, although in that case I got a popup saying
"C:\Users\gordonp\Documents\NetBeansProjects\Arguments_1 does not exist or is
not an executable." I retried with MinGW and got identical behavior.

I'm closing this issue as INVALID. If you can still duplicate the problem then
please open a new issue. This one is about attach failing and reopening it about
Debug failing is a different issue (it makes it harder for me to keep track of
fixes when an issue significantly differs from what it was originally opened as).
Comment 4 Alexander Pepin 2009-01-13 14:59:06 UTC
The issue is fixed from debugger point of view but described issue exists and should be fixed in 'projects' subcomponent
so I will open a new issue against 'projects' on Windows platform. 
Comment 5 Alexander Pepin 2009-01-13 14:59:45 UTC
fixed in gdb subcomponent
Comment 6 Alexander Pepin 2009-01-13 15:00:23 UTC
verified in build 20090113092345
Comment 7 jinb 2009-01-14 17:43:46 UTC
Cumulative backport of fixes of IZ 151481(rebackport), 151577, 151610, 153473, 151640, 151761, 155487, 151631, 133134
provided by developer.
Backported into release65_fixes branch
http://hg.netbeans.org/release65_fixes/rev/84a0c7175a4b
Comment 8 jinb 2009-01-14 19:25:01 UTC
Additional changeset (made on base of http://hg.netbeans.org/main?cmd=changeset;node=e91345591cb6): need to be
backported into release65_fixes:
http://hg.netbeans.org/release65_fixes/rev/79ab9c120b5a
Comment 9 Alexander Pepin 2009-01-19 16:18:53 UTC
verified in patch2
Comment 10 poolbewohner 2009-03-04 19:07:48 UTC
With a fully updated Netbeans 6.5 (via "Reload Catalog" in Plugin-Manager) I'm now getting

"The project's Build Result property is not an absolute path."

as an error.

The code for this error message was added in the latest fix for this bug.
Do I understand it right when this should be fixed also in updated versions of Netbeans 6.5? When I try to convert the
project to "Application" type I get the problem described in #159063

How often are the bugfixes released (I have a project where I need "attach to process" quite frequently, and we have a
hard deadline at 2009-04-20 ;-) )?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo