Bug 153453 - New Watch Dialog Code Completition Throws Exception
New Watch Dialog Code Completition Throws Exception
Status: VERIFIED DUPLICATE of bug 153403
Product: java
Classification: Unclassified
Component: Source
6.x
All Linux
: P3 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 13:12 UTC by Filip Zamboj
Modified: 2009-02-19 21:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (292.80 KB, image/png)
2008-11-19 13:13 UTC, Filip Zamboj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Zamboj 2008-11-19 13:12:20 UTC
description: java.lang.NullPointerException occurs when trying to add expression System.getProperty to new watch dialog.
Expression is thrown right after code completition window appears

Attachments: screenshot

java -version: 1.5.0_17
nb build 081114

Stack Trace: 
java.lang.NullPointerException: The cpInfo parameter cannot be null
	at org.openide.util.Parameters.notNull(Parameters.java:86)
	at org.netbeans.api.java.source.SourceUtils.getFile(SourceUtils.java:366)
	at org.netbeans.modules.editor.java.JavaCompletionProvider$JavaCompletionQuery.query(JavaCompletionProvider.java:265)
	at org.netbeans.spi.editor.completion.support.AsyncCompletionTask.run(AsyncCompletionTask.java:218)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
Comment 1 Filip Zamboj 2008-11-19 13:13:14 UTC
Created attachment 73905 [details]
screenshot
Comment 2 Jan Lahoda 2008-11-21 07:36:06 UTC

*** This issue has been marked as a duplicate of 153403 ***
Comment 3 Filip Zamboj 2008-11-21 15:15:34 UTC
no exception thrown anymore


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo