Bug 153195 - i18N japanese http bindings property sheet is bad
i18N japanese http bindings property sheet is bad
Status: RESOLVED FIXED
Product: soa
Classification: Unclassified
Component: HTTP BC
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Sherry Weng
issues@soa
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 07:32 UTC by schmandt
Modified: 2009-04-28 07:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
english http binding property sheet (225.91 KB, image/jpeg)
2008-11-14 07:54 UTC, schmandt
Details
japanese http binding property sheet (193.33 KB, image/jpeg)
2008-11-14 07:55 UTC, schmandt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schmandt 2008-11-14 07:32:55 UTC
for capsr6u1 in 1029 build on japanese locale

in ide->services->glassfish->jbi>binding components->sun http binding->right click and 
select properties.  the english properties sheet in my gfesb 1110 build shows 5 sections:
general,identification,configuration,statistics,logging.

on japanese locale in the caps6u1 build, the same sheet is missing the important
"configuration" section.  I'm guessing this is just a bad japanese
properties file which is missing this section.  the gfesb version is not localized
so i see the english even on japanese locale.

i have no idea where the relevant jar file is, what folder under .netbeans this
is in, so i cannot figure out which property file is bad.  

note that the http binding is the only one i know of that has the
configuration section, this is by design.  i will attach screen shots of the
english and the japanese, even if you can't read japanese you can
notice that there are only 4 sections where the english has 5.
Comment 1 schmandt 2008-11-14 07:45:55 UTC
I'm not sure if this is a caps i18n team issue or nb i18n team.
please reassign and sort it out asap.  seems like this ought
to be simple to fix for caps6r1 in the japanese translations.
Comment 2 schmandt 2008-11-14 07:54:11 UTC
Created attachment 73761 [details]
english http binding property sheet
Comment 3 schmandt 2008-11-14 07:55:02 UTC
Created attachment 73762 [details]
japanese http binding property sheet
Comment 4 Masaki Katakai 2008-11-19 05:39:41 UTC
I can see "configuration" section even in Japanese locale once I started the component.

Could you try again?
Comment 5 schmandt 2008-11-21 22:16:51 UTC
please look at my japanese property sheet which is attached, it shows the component is started (3rd line),
so the problem is not simply that the bc is not started.

what build are you looking at?  

I'm now using  capsr6u1 build dated 11/10 and i see the same problem.
I'm running on win-xp in japanese locale.

i now have the travel reservation sample project deployed and i see endpoint statistics 
showing 8-9 http ports like hotelreservationsoaphttpport etc.
Comment 6 Marian Mirilovic 2009-02-20 18:07:56 UTC
update no67 keyword
Comment 7 Jun Qian 2009-03-09 22:30:42 UTC
Other components also have Configuration section, for example, BPEL SE, FILE BC... Please try the other components in
Japanese locale and see if this problem is HTTP BC specific, or generic across the board.

The i18n file for component configuration is not in Netbeans. It should be in the component jar file inside GlassFish.
Check the NetBeans log file to see if there is any error/warning message regarding component configuration.

Comment 8 Jun Qian 2009-04-09 22:01:27 UTC
Reassinging to http bc owner...
Comment 9 Sherry Weng 2009-04-14 00:42:26 UTC
Fixed.
Comment 10 leova 2009-04-28 07:58:49 UTC
I couldn't verify it as we don't provide japanese version for GFv2.1 this time.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo