Bug 152852 - Error while trying to save view to image in CPU snapshot
Error while trying to save view to image in CPU snapshot
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Petr Cyhelsky
issues@profiler
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 11:04 UTC by Rashid Urusov
Modified: 2009-05-22 12:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rashid Urusov 2008-11-10 11:04:17 UTC
Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_07; Java HotSpot(TM) Client VM 10.0-b23
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)
Userdir: C:\Documents and Settings\user\.netbeans\6.5

Steps to reproduce:

- Start CPU profiling of Anagram Game
- Take  CPU snapshot
- Switch to Info tab of CPU snapshot
- Push "Save current view to image" button in snapshot toolbar

I've got Error message "No view to save"
Comment 1 Petr Cyhelsky 2008-12-12 09:38:08 UTC
Reproduced. This seems to be more of an ui issue. Because the info view is just text and no graphs are there, it doesn't
make much sense that the save as image button is even enabled. I agree, that the error dialog seems out of place here.
Comment 2 Petr Cyhelsky 2009-01-12 16:24:56 UTC
fixed in profiler-main:
2811c50a6d12
Comment 3 mariadavydova 2009-01-14 14:40:01 UTC
verified in build dev 200901121401
Comment 4 Quality Engineering 2009-01-24 18:50:40 UTC
Integrated into 'main-golden', will be available in build *200901241401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2811c50a6d12
User: Petr Cyhelsky <cyhelsky@netbeans.org>
Log: #152852 disabling save view to image button on info view to prevent error message


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo