Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 152833 - Updating Invocation text cause the IDE to freeze
Updating Invocation text cause the IDE to freeze
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Diagram Activity
6.x
PC All
: P2 (vote)
: 6.x
Assigned To: Sergey Petrov
issues@uml
65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 04:01 UTC by jirka_x1
Modified: 2009-07-12 07:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
ThreadDump (via StackTrace) (22.36 KB, text/plain)
2008-11-10 04:03 UTC, jirka_x1
Details
Created an attachment (id=73749) THe freeze happened during editing "tag back translation" (68.27 KB, text/plain)
2008-11-13 18:44 UTC, jirka_x1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jirka_x1 2008-11-10 04:01:39 UTC
Updating Invocation text cause the IDE to freeze
Comment 1 jirka_x1 2008-11-10 04:03:10 UTC
Created attachment 73564 [details]
ThreadDump (via StackTrace)
Comment 2 jirka_x1 2008-11-10 04:11:45 UTC
Actually, it looks that it might not freeze completely just got very busy. I selected "Close" from Windows menu and
after about 10 min it displayed the Save modified files dialog (still very irresponsive, the main window did not
redraw), and after 2 min or so it probably accepted my save all and closed.
Comment 3 Sergey Petrov 2008-11-10 04:51:38 UTC
is it reproducible? was invocation size default? and what text was entered?
Comment 4 jirka_x1 2008-11-13 18:41:41 UTC
> is it reproducible? 
No. I restarted, did the same thing again and it worked.

> was invocation size default? 

I think so. 

and what text was entered?
"tag back translation" (If I remember it correctly, I pressed Ctrl+Enter after "tag", right before the freeze)

I will attach the image of the resulting diagram (finished after restart), the freeze happened when editing "tag back
translation" 
Comment 5 jirka_x1 2008-11-13 18:44:46 UTC
Created attachment 73750 [details]
Created an attachment (id=73749) THe freeze happened during editing "tag back translation"
Comment 6 Sergey Petrov 2008-11-21 14:26:20 UTC
got out of memory/heap space trying to reproduce the issue with invocation resizing.
most likely initial issue is the same even I got exception faster then in 10 minutes.
Comment 7 Sergey Petrov 2008-11-24 14:28:12 UTC
it was something in wrap logic, can't reproduce any more with the fix. wrap logic is two level now and more simple in my
opinion.
61a69d9e3480
Comment 8 Quality Engineering 2008-11-25 16:46:13 UTC
Integrated into 'main-golden', will be available in build *200811251401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/61a69d9e3480
User: sergeyp@netbeans.org
Log: fix #152833 - reqrite newline splitting, so '\n' splitting have more simple logic now separated from word wrapping, also some words do not disappear now on dofferent sizes of widget. can't reproduce freeze with this fix.
Comment 9 Peter Lam 2008-12-04 21:49:49 UTC
verified in trunk build 20081203
Comment 10 Peter Lam 2008-12-17 18:01:14 UTC
re-verified in latest trunk build 20081217.
Comment 11 rbalada 2009-01-15 15:25:47 UTC
I've backported the changeset http://hg.netbeans.org/main/rev/61a69d9e3480 into release65_fixes repository as
http://hg.netbeans.org/release65_fixes/rev/7beda9079361
Comment 12 kaa 2009-01-22 16:39:44 UTC
re-verified with 65patch2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo