Bug 152448 - Add note to the documentation about MySQL 5.0 limitation
Add note to the documentation about MySQL 5.0 limitation
Status: VERIFIED FIXED
Product: usersguide
Classification: Unclassified
Component: Database
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: James Branam
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes3-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 19:34 UTC by Roman Mostyka
Modified: 2009-10-02 14:13 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (160 bytes, text/plain)
2008-11-05 19:34 UTC, Roman Mostyka
Details
stacktrace (1.85 KB, text/plain)
2008-11-29 21:17 UTC, Roman Mostyka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-11-05 19:34:44 UTC
Build: NetBeans IDE Dev (Build 081105)
VM: Java HotSpot(TM) Client VM, 11.0-b13, Java(TM) SE Runtime Environment, 1.6.0_10-rc-b26
OS: Windows XP, 5.1, x86

User Comments:
romanmostyka: 1. Start MySQL server.
2. Rightclick it's node, choose "Creata Database..." and enter "test*1" for database name.

Result: Exception arises.



Stacktrace: 
java.lang.Exception: The database command createDatabase failed with the following exception:
        at org.netbeans.modules.db.mysql.impl.MySQLDatabaseServer$DatabaseCommand.run(MySQLDatabaseServer.java:981)
        at org.netbeans.modules.db.mysql.impl.ConnectionProcessor.run(ConnectionProcessor.java:144)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
Comment 1 Roman Mostyka 2008-11-05 19:34:53 UTC
Created attachment 73319 [details]
stacktrace
Comment 2 David Vancouvering 2008-11-05 20:46:40 UTC

*** This issue has been marked as a duplicate of 152107 ***
Comment 3 Roman Mostyka 2008-11-07 08:43:55 UTC
It's not duplicate.
David, have you tried your fix on Windows XP? I tried on Mac OS X and everything is fine there, but on my Windows XP in
Russian locale I'm constantly able to reproduce this issue. And I see changes from your changeset. Please pay more
attention to this issue, it can affect Windows users. I can provide all necessary information if you need it.
Comment 4 Roman Mostyka 2008-11-29 21:17:15 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows XP, 5.1, x86

User Comments: 
1. Install MySQL !!!5.0!!! server.
2. Start IDE with fresh userdir. MySQL server should be automatically registered under "Databases" node.
3. Start MySQL.
4. Rightclick MySQL server's node and choose "Create Database".
5. Set "test*1" for DB name and click "OK". Error message should appear.
6. Rightclick connection's node for those DB and choose "Delete".

Result: Exception arises.

Stacktrace: 
java.lang.Exception: The database command dropDatabase failed with the following exception:
        at org.netbeans.modules.db.mysql.impl.MySQLDatabaseServer$DatabaseCommand.run(MySQLDatabaseServer.java:980)
        at org.netbeans.modules.db.mysql.impl.ConnectionProcessor.run(ConnectionProcessor.java:138)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:572)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:997)
Comment 5 Roman Mostyka 2008-11-29 21:17:25 UTC
Created attachment 74304 [details]
stacktrace
Comment 6 Roman Mostyka 2008-11-29 21:20:12 UTC
David, it's not duplicate, it's specific issue for MySQL 5.0. I tried with MySQL 5.1 and everything was fine. Therefore
issue #152107 was fixed.
But this specific didn't. So I marked it as Patch 2 candidate.
Comment 7 David Vancouvering 2008-12-05 21:25:15 UTC
Hi, Roman.  Sorry, but this is a limitation of MySQL on Windows, and there's nothing I can do about it.  

On *Windows* with *MySQL 5.0* I can create databases with other character strings that need to be quoted, such as
multibyte Japanese characters and 'test-1' and 'test 1' but 'test*1' fails not only within NetBeans but also from the
MySQL command line:

mysql> create database `test*1`;
ERROR 1006 (HY000): Can't create database 'test*1' (errno: 22)
Comment 8 Roman Mostyka 2008-12-07 01:44:55 UTC
I understand. Then I think we should have some note about this in documentation.
I've changed summary and subcomponent.
Comment 9 Roman Mostyka 2008-12-07 01:46:48 UTC
James, can we have note about MySQL 5.0 limitation in documentation? Or you think it isn't in our scope? If not, then
please close this issue.
Thanks.
Comment 10 James Branam 2008-12-12 17:46:49 UTC
This information will be added.
Comment 11 pgebauer 2009-01-14 09:48:37 UTC
The issue hasn't passed the nomination process for 65patch2 by cut-off date. It has been moved to 65patch3.
Comment 12 James Branam 2009-02-10 13:18:57 UTC
I added the following note to the topic.

Note: When using MySQL 5.0 with Windows, some foreign characters may not be used when creating a database.
Comment 13 Martin Schovanek 2009-02-27 08:06:29 UTC
v.
Comment 14 Marian Mirilovic 2009-03-02 08:49:13 UTC
http://hg.netbeans.org/main/rev/1279ff8f53d8

James, could you please proceed with porting this bugfix into release65_fixes clone ?
http://wiki.netbeans.org/NetBeans6.5.1BugFixes

Thanks in advance.
Comment 15 James Branam 2009-03-02 11:18:00 UTC
Fixed in release65_fixes
Comment 16 Jaroslav Pospisil 2009-03-05 16:39:53 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo