Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 152353 - ServiceProviderProcessor from classpath preferred to developed version
ServiceProviderProcessor from classpath preferred to developed version
Status: RESOLVED DUPLICATE of bug 152620
Product: apisupport
Classification: Unclassified
Component: Harness
6.x
All All
: P4 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
:
Depends on:
Blocks: 147393
  Show dependency treegraph
 
Reported: 2008-11-04 19:44 UTC by Jesse Glick
Modified: 2009-02-19 20:18 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-11-04 19:44:55 UTC
It seems that when running Ant on a module project from inside a 7.0+ IDE then the processor for @ServiceProvider is
taken from the IDE's org-openide-util.jar rather than from the copy you are developing in a module project. This makes
it more difficult to test changes to ServiceProviderProcessor.

Presumably the same would apply to any other provider located in openide.util, openide.modules, or o.n.bootstrap. Might
be best solvable by hacking the Ant module to specifically exclude NB platform JARs from the classpath it reports to
Apache Ant.

Calling setIncludeantruntime(false) and setIncludejavaruntime(false) in CustomJavac does not help.
Comment 1 Jesse Glick 2008-11-24 19:36:59 UTC
Seems to be fixed by fix of issue #152620 (the "best solvable" part).

*** This issue has been marked as a duplicate of 152620 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo