Bug 151902 - SQLite3 databasefile stays locked after disconnecting
SQLite3 databasefile stays locked after disconnecting
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 20:45 UTC by raskolnikov
Modified: 2009-09-03 15:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raskolnikov 2008-10-30 20:45:14 UTC
To reproduce:

1) Create a database with SQLite
2) Connect to it in Netbeans
3) Disconnect the database (or even delete the connection) 
4) Try to delete the databasefile from Explorer or via a script 

This creates an "access denied" error.
Comment 1 David Vancouvering 2008-10-30 22:01:37 UTC
SQLite is not currently a supported database, so I am sorry but this is not a P2.  We will fix it as we can.  
Comment 2 raskolnikov 2008-10-30 23:27:10 UTC
Hi David!

Ok, fine.

Btw.: Why isn't SQLite a supported db, as I'm reading all the time? It's very popular and very handy on the desktop.
Shouldn't it become supported? Who decides that? This is no accusation - I'm just curious.

Cheers, 
Raskolnikov.
Comment 3 David Vancouvering 2008-10-31 18:48:47 UTC
Hi, Raskolnikov.  SQLite is an excellent database, and is being used in more and more places.  It would be nice to
support it.  But to be honest when we work with users, it is not commonly requested right now.  We have our hands full
with MySQL, Oracle, MS SQL Server, PostgreSQL, Java DB and DB2.  There are a bunch of databases that people use but
which we don't test against or provide "official" support - but we make our best effort to get it to work.

It's particularly hard to support SQLite since it (a) has absolutely no metadata support in its JDBC driver, so it's
useless in the Database Explorer and (b) it's embedded, and thus behaves differently from standard client/server
databases.  So it would take some concerted effort to get it working.  I'd like to do this, but there are only so many
hours in the day.

You are helping *a lot* by reporting bugs.  If you would like to help yourself and many others out, it would be GREAT if
you actually wanted to submit patches with suggested fixes.  I would be more than happy to provide you support as you
get the source code and build environment set up, and to point you to the relevant areas of the code.
Comment 4 raskolnikov 2008-10-31 23:13:45 UTC
Hi David,

can we communicate on another "channel" than via this issue (thus putting a lot of noise in it)?
I'm new to this community and I suppose there's something like "private message" or so...

But in the first place I have to discourage you since I'm no Java programmer and have only written a few dozens lines of
java-code in my life... Nevertheless I could try to fix (very) minor issues like nr 150275.

I would like to contribute if it doesn't take me forever to get into the matter... one never knows: perhaps it's possible.

For the next 2 weeks I'll be away in holidays.

See you then,
Raskolnikov.
Comment 5 Jiri Rechtacek 2009-02-10 15:37:40 UTC
Reassigned to new owner.
Comment 6 Jiri Rechtacek 2009-09-03 15:13:29 UTC
Should be fixed since NB6.8M1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo