Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151631 - Endless *this chain in Watches
Endless *this chain in Watches
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: _ gordonp
issues@cnd
65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 18:21 UTC by Alexander Pepin
Modified: 2009-06-25 10:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (165.62 KB, image/jpeg)
2008-10-28 18:22 UTC, Alexander Pepin
Details
gdb log (13.22 KB, text/plain)
2008-10-28 18:24 UTC, Alexander Pepin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2008-10-28 18:21:48 UTC
While debugging a real-life application I observed the following endless chain of *this in Watches (see attached screenshot)
Comment 1 Alexander Pepin 2008-10-28 18:22:48 UTC
Created attachment 72791 [details]
screenshot
Comment 2 Alexander Pepin 2008-10-28 18:24:34 UTC
Created attachment 72792 [details]
gdb log
Comment 3 _ gordonp 2008-12-24 16:04:36 UTC
I could not duplicate this problem. Can you attach a minimal test case which demonstrates
the problem? It looks like its using Wind32 and/or COM APIs and I've got no experience
there. If its possible to give me a very simple tarball containing a test case it would
make it easier to duplicate and fix. Thanks!

Also, do you see similar behavior expanding "this" in the Local Variables view?
Comment 4 _ gordonp 2008-12-24 17:08:09 UTC
I looked further at the gdb log file and part of the problem is that when the IDE asks gdb for
type information for "this" gdb returns an error message saying there is no "this" in the current
scope (this may be a user error but I can't say for sure).

If I setup a similar environment and override the return of the type request with a similar error,
I get the recurring this->*this behavior. So it looks like I can set this scenario up via some
hacking. If so, I should also be able to set up a test to correctly deal with it.

This means I won't be able to expand "this" if gdb doesn't tell me its type.
Comment 5 _ gordonp 2009-01-05 22:35:45 UTC
After getting Alexander's test case (via email) I've completed the fix for this issue. The 1st part
of the fix was in changeset http://hg.netbeans.org/main/rev/2ec6a02936a7. Today's part is in changeset
http://hg.netbeans.org/main/rev/15f42a816c6e.
Comment 6 jinb 2009-01-07 19:40:10 UTC
QA, please verify this fix till 14-Jan-2009, so it can be part of NB 6.5 patch 2.
Comment 7 Alexander Pepin 2009-01-13 13:29:35 UTC
verified in build 20090113092345
Comment 8 Alexander Pepin 2009-01-13 15:17:23 UTC
It would be nice to have the fix in NB 6.5 patch
Comment 9 Alexander Pepin 2009-01-14 14:26:55 UTC
verified in NB6.5 with provided jar files
Comment 10 jinb 2009-01-14 17:44:16 UTC
Cumulative backport of fixes of IZ 151481(rebackport), 151577, 151610, 153473, 151640, 151761, 155487, 151631, 133134
provided by developer.
Backported into release65_fixes branch
http://hg.netbeans.org/release65_fixes/rev/84a0c7175a4b
Comment 11 Alexander Pepin 2009-01-19 15:21:43 UTC
verified in patch2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo