Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151466 - Description "url (user on SCHEMA)" is unhelpful
Description "url (user on SCHEMA)" is unhelpful
Status: RESOLVED DUPLICATE of bug 144112
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: TBD
Assigned To: David Vancouvering
issues@db
:
Depends on:
Blocks: 152816
  Show dependency treegraph
 
Reported: 2008-10-27 13:53 UTC by entonio
Modified: 2009-09-08 14:07 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Notice how the oracle connextions are barely indistinguishable (completely, in the case of the two :dev11) (20.48 KB, image/png)
2008-10-27 13:58 UTC, entonio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description entonio 2008-10-27 13:53:56 UTC
Hi,
The database explorer is a very nice tool, but I have a problem with the connection listing: each connection is listed
as "url [user on SCHEMA]" and this makes it hard to read, since 1) sorting is done by url, which isn't usually helpful,
and more grievous 2) the url takes up a lot of space and at least for me that means the pane must have a lot more width
than necessary or convenient just to be able to see what user this is; and as you know, user/schema is usually the most
important information, so I think it should come first. In my case, for instance, I have a lot of connections which
differ only in user/schema (well, the derby connections that come with nb are almost as good an example), which means I
can't distinguish them at all using my normal width for the services pane (I'll attach an example image).

I think this should be easy to solve, just make the description "user on SCHEMA (url)" or some variant which makes sure
the user is presented first. As it is, it's a usability fault, imo. Thanks.
Comment 1 entonio 2008-10-27 13:58:38 UTC
Created attachment 72684 [details]
Notice how the oracle connextions are barely indistinguishable (completely, in the case of the two :dev11)
Comment 2 Jiri Skrivanek 2009-09-08 14:07:46 UTC

*** This issue has been marked as a duplicate of 144112 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo