Bug 150568 - [toolbars] StackOverflowError at java.awt.font.FontRenderContext.hashCode
[toolbars] StackOverflowError at java.awt.font.FontRenderContext.hashCode
Status: RESOLVED INVALID
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT issue_reviewed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 17:26 UTC by setdosa
Modified: 2009-02-19 22:53 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (116.09 KB, text/plain)
2008-10-17 17:26 UTC, setdosa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description setdosa 2008-10-17 17:26:21 UTC
Build: NetBeans IDE Dev (Build 200810140201)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-rc-b28
OS: Linux, 2.6.24-19-generic, i386

User Comments:
GUEST: starting netbeans from my ubuntu desktop icon

GUEST: Just changed my ubuntu theme and there appeared the error icon on netbeans

GUEST: Starting up NetBeans.

idecasso: I was opening Netbeans,  but before I was use netbeans 6.0

GUEST: I was starting Netbeans for the first time after install.

GUEST: just start up the ide.

jonasklingstedt: Just starting the IDE...

jonasklingstedt: Just starting the IDE after a fresh install

pietrangelo: I was trying to move palette from its original position

pietrangelo: just open the ide

pietrangelo: starting th ide

GUEST: I was starting Netbeans.

GUEST: The Error Occurs eacht time I try to start Netbeans 6.1

GUEST: Nebeans throws this error during start and continues loading normally

GUEST: on startup

GUEST: on startup

jemmyw: Starting netbeans



Stacktrace: 
java.lang.StackOverflowError
        at java.awt.font.FontRenderContext.hashCode(FontRenderContext.java:335)
        at sun.font.FontDesignMetrics$MetricsKey.init(FontDesignMetrics.java:199)
        at sun.font.FontDesignMetrics.getMetrics(FontDesignMetrics.java:267)
        at sun.swing.SwingUtilities2.getFontMetrics(SwingUtilities2.java:984)
        at javax.swing.JComponent.getFontMetrics(JComponent.java:1597)
        at javax.swing.plaf.synth.SynthGraphicsUtils.getPreferredSize(SynthGraphicsUtils.java:264)
Comment 1 setdosa 2008-10-17 17:26:32 UTC
Created attachment 72140 [details]
stacktrace
Comment 2 Peter Pis 2008-10-17 20:42:35 UTC
Any further details are highly appreciated. Anyway, can you reproduce this with fresh user dir?

http://wiki.netbeans.org/FaqAlternateUserdir
Comment 3 Peter Pis 2008-11-03 09:32:07 UTC
"core" could you please evaluate?
Comment 4 matusdekanek 2008-11-05 08:39:02 UTC
I found an exception, which was duplicate of an exception, which led to this issue and I made a bit of research on it. 
I tried following:
opened IDE
disabled view of 'build toolbar'
enabled view of 'debug toolbar'
closed IDE
opened IDE again
if IDE had not clear userdir, an exception occured (and was found as a duplicate of an exception, which led to this 
issue). Because of saved settings of user, IDE had to be reinstalled and saved user data removed, because IDE could not 
even start. This was observed on NB 6.5 RC1, NB 6.5 RC2 and NB 6.5 nightly 20081103

If IDE had clear userdir, it did not throw exception, however the GUI was not correctly shown. For example, I disabled 
view of both debug and build toolbars, but they are both visible. Playing with disabling/enabling these toolbars will 
reveal more similar problems, such as incorrect poisiition of toolbar etc. 
Opening a project did not cause exception, as well as playing with view of these toolbars after opening this project. 
However, disabling/enabling debug or build toolbar had no effect, they were still shown (on strange positions). This 
was observed on NB 6.5 RC2

I hope it helped

System config:
Product Version: NetBeans IDE 6.5 RC2 (Build 200810270001)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
System: Linux version 2.6.24-21-generic running on i386; UTF-8; en_US (nb)
compiz disabled
(btw, maybe raising the priority of this issue would be appropriate, this bug may lead to inusability of IDE)
Comment 5 Lukas Hasik 2008-11-19 12:24:23 UTC
44 duplicates -> TM=7.0
Comment 6 Stanislav Aubrecht 2008-12-05 11:00:08 UTC
toolbar implementation has been completely rewritten
please reopen if this issue is still reproducible in latest builds
Comment 7 arirebeca 2009-01-08 13:51:49 UTC
I fixed this issue removing the folder "Toolbars" on Netbeans config folder. There's a file there that may be broken.
The file is "Standard.xml" and the content (This file may be broken):
<?xml version="1.0"?>

<!DOCTYPE Configuration PUBLIC "-//NetBeans IDE//DTD toolbar//EN" "http://www.netbeans.org/dtds/toolbar.dtd">

<Configuration>
  <Row>
    <Toolbar name="Memory" position="0" visible="false" />
    <Toolbar name="Clipboard" position="0" visible="false" />
    <Toolbar name="File" />
    <Toolbar name="Debug" />
    <Toolbar name="UndoRedo" />
    <Toolbar name="Build" />
    <Toolbar name="Edit" />
    <Toolbar name="QuickSearch" />
  </Row>
  <Row>
    <Toolbar name="File" />
    <Toolbar name="Build" />
    <Toolbar name="Edit" />
    <Toolbar name="UndoRedo" />
  </Row>
</Configuration>
Comment 8 Stanislav Aubrecht 2009-01-08 13:57:02 UTC
arirebeca, which version of netbeans did you reproduce this issue in?
Comment 9 arirebeca 2009-01-08 14:26:04 UTC
Versão do produto: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
Sistema: Linux versão 2.6.27-11-generic executando em i386; UTF-8; pt_BR (nb)
Diretório do usuário: /home/ari/.netbeans/6.5

I am using Ubuntu 8.10, when I was using 8.04 that error didn't show up. Maybe there's something about Ubuntu 8.10.
After removing the folder I said before, Netbeans is working great.
Comment 10 Stanislav Aubrecht 2009-01-08 14:52:00 UTC
toolbar rewrite patch propagated into the main repository on nov 29th 2008
please only reopen this issue if reproducible in builds older than the date above


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo