Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 150034 - java.io.IOException: Not in GZIP format
java.io.IOException: Not in GZIP format
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P2 (vote)
: 6.x
Assigned To: dlipin
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes1-verified
:
: 151487 153667 159764 (view as bug list)
Depends on:
Blocks: 152010
  Show dependency treegraph
 
Reported: 2008-10-14 10:14 UTC by Lukas Hasik
Modified: 2009-03-18 15:49 UTC (History)
44 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.76 KB, text/plain)
2009-03-08 09:52 UTC, goeh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-10-14 10:14:06 UTC
17 duplicates

Build: NetBeans IDE Dev (Build 200808260201)
VM: Java HotSpot(TM) Client VM, 1.5.0_14-b03, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_14-b03
OS: SunOS, 5.10, sparc
User comments: open project
STACKTRACE: (first 10 lines)
java.io.IOException: Not in GZIP format
        at java.util.zip.GZIPInputStream.readHeader(GZIPInputStream.java:132)
        at java.util.zip.GZIPInputStream.<init>(GZIPInputStream.java:58)
        at java.util.zip.GZIPInputStream.<init>(GZIPInputStream.java:68)
        at
org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogParser.getInputSource(AutoupdateCatalogParser.java:176)
        at
org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogParser.getUpdateItems(AutoupdateCatalogParser.java:148)
        at
org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogProvider.getUpdateItems(AutoupdateCatalogProvider.java:110)
        at org.netbeans.modules.autoupdate.services.UpdateUnitFactory.appendUpdateItems(UpdateUnitFactory.java:170)
        at org.netbeans.modules.autoupdate.services.UpdateUnitFactory.getUpdateUnits(UpdateUnitFactory.java:140)
        at org.netbeans.modules.autoupdate.services.UpdateManagerImpl$Cache.<init>(UpdateManagerImpl.java:221)
        at org.netbeans.modules.autoupdate.services.UpdateManagerImpl.getCache(UpdateManagerImpl.java:195)
Comment 1 Jiri Rechtacek 2008-10-17 21:01:26 UTC
Need to catch it and report which URL has the problem.
Comment 2 Marian Mirilovic 2008-10-31 17:16:36 UTC
39 duplicates and still rising .... would be nice to fix this in 6.5 patch 1
Comment 3 Jiri Rechtacek 2008-10-31 17:26:01 UTC
Marian, can you reproduce it?
Comment 4 Jiri Rechtacek 2008-11-01 10:16:44 UTC
I guess it's caused by wrong content of UC. I added more logging in recent dev builds but nobody has reported there such
problems yet. I really need a reproducible case. Does anybody have any one? Thanks
Comment 5 Jiri Rechtacek 2008-11-05 10:03:48 UTC
*** Issue 151487 has been marked as a duplicate of this issue. ***
Comment 6 Jiri Rechtacek 2008-11-05 10:16:22 UTC
Cache file could become a empty (0B length) in some but unknown cases. Once a case became empty file, then the parser
throws this exception.
Catching/handling of such cases fixed in rev/decdbc34af1f
Comment 7 Quality Engineering 2008-11-06 05:20:49 UTC
Integrated into 'main-golden', will be available in build *200811060201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/decdbc34af1f
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #150034: java.io.IOException: Not in GZIP format
Comment 8 Jaromir Uhrik 2008-11-19 14:28:42 UTC
Verified.
Comment 9 mouse256 2008-11-20 11:27:32 UTC
I don't see the answer here right now. It seems the issue is fixed, but is it also in the final version of 6.5? I just
had the issue there.
Comment 10 pgebauer 2008-11-20 11:53:49 UTC
The issue is Fixed/Verified in the main repository as you can see at http://hg.netbeans.org/main/rev/decdbc34af1f . Its
target milestone is 7.0M1 so it is not part of NetBeans IDE 6.5. Since it's marked as 65fixes1-candidate, it should be
part of the proactive patch "65patch1". For more info about proactive patches, please see
http://wiki.netbeans.org/NetBeansPatchesInfo .
Comment 11 pgebauer 2008-11-21 10:17:59 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/28110b09a042

Comment 12 dlipin 2008-11-21 21:27:50 UTC
*** Issue 153667 has been marked as a duplicate of this issue. ***
Comment 13 Exceptions Reporter 2008-11-25 13:41:29 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200811200201)
http://statistics.netbeans.org/exceptions/detail.do?id=142076
Comment 14 kaa 2008-11-25 17:28:10 UTC
I re-checked with 1125 trunk build. The issue is not reproducible.
Comment 15 pavla 2008-11-26 16:53:54 UTC
Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

I had exactly same problem as described in ISSUE 153667: "NB 6.5 just installed. Clicked on Tools -> Plugins the plugins
window contains 4 plugins only and the IDE shows this bug". 

More details and solutions that worked for me:
All update centers (plugin portal, netbeans, netbeans beta and 3rd party) checked (settings tab)-> I hit "reload
catalog" and got the exception (only 4 available plugins from plugin portal were present). I unchecked all update
centers. When I checked plugin portal update center only - no problem, when I checked one of nebeans, netbeans beta and
3rd party I got the exception again. When I turned my firewall off and hit "reload catalog" exception didn't arise and
plugins from all update centers were present. When I turned firewall on (and hit reload catalog) exception arised again
(also only 4 available plugin were present again). I don't know which of firewall rules blocked the operation, I had no
explicit blocks on netbeans application or netbeans website.



Comment 16 pgebauer 2008-11-26 18:52:56 UTC
Hi Pavla,

I appreciate your issue report. The NetBeans team is aware of this issue and we are currently working on the remedy. FYI: The issue has been fixed and 
verified in the source code for the next NetBeans IDE release. Due to that, the status VERIFIED was assigned to the issue. Please, do not change it. Besides, 
the issue has been marked as the candidate for the 65patch1, so once it is released on Stable Auto Update Center, you will be able to apply the fix to your 
NetBeans IDE 6.5. For more info, please check http://wiki.netbeans.org/NetBeansPatchesInfo and http://wiki.netbeans.org/NetBeans65Patch1Plan .

I'm marking the issue back as VERIFIED/FIXED.

Comment 17 pgebauer 2008-11-26 18:53:39 UTC
v.
Comment 18 Jaromir Uhrik 2008-12-02 15:33:34 UTC
Cannot reproduce - changing the status whiteboard to 65fixes1-verified.
Comment 19 Jaromir Uhrik 2008-12-02 15:42:09 UTC
I forgot to mention that it cannot be reproduced in the build below containing 6.5 patch1.

Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 20 amitksaha 2008-12-07 04:55:59 UTC
I am facing this issue on NetBeans IDE 6.5 on Linux
Comment 21 Lukas Hasik 2008-12-07 14:26:18 UTC
i'm closing again as fixed. *This issue can happen in NB 6.5*. It was fixed in NB7.0 and patch 1 for NB6.5
Please, reopen only if you are able to reproduce it with NB6.5+patch1 or NB 7.0

For more details look at desc17 from pgebauer.
thank you
Comment 22 diggywang 2008-12-08 01:17:23 UTC
but where can i get Patch 1?
Comment 23 pslechta 2008-12-08 09:51:23 UTC
The NB 6.5 patch 1 should be on update center on Dec 11th. When it is available, you can apply the patch via Plugin
Manager (menu Tools > Plugins > tab Updates > button Install).
Comment 24 boyxuper 2008-12-09 09:12:39 UTC
in tools=>plugins=>settings
edit every entry, and remove .gz extension

and there is something maybe nb 6.5 patch1 
in tools=>plugins=>settings
disable all other checkbox
click add
input URL:
http://updates.netbeans.org/netbeans/updates/6.5/uc/final/stable/catalog_stage.xml

i did that
Comment 25 boyxuper 2008-12-09 09:12:52 UTC
in tools=>plugins=>settings
edit every entry, and remove .gz extension

and there is something maybe nb 6.5 patch1 
in tools=>plugins=>settings
disable all other checkbox
click add
input URL:
http://updates.netbeans.org/netbeans/updates/6.5/uc/final/stable/catalog_stage.xml

i did that
Comment 26 Jiri Rechtacek 2008-12-09 09:26:22 UTC
> ------- Additional comments from boyxuper@netbeans.org Tue Dec  9 09:12:52 +0000 2008 -------
> in tools=>plugins=>settings
> edit every entry, and remove .gz extension
Right, it's an another issue which has no connection with this issue. boyxuper please file new issue about this edge
case with a correct priority, P4 I guess. Thanks
> 
> and there is something maybe nb 6.5 patch1 
> in tools=>plugins=>settings
> disable all other checkbox
> click add
> input URL:
> http://updates.netbeans.org/netbeans/updates/6.5/uc/final/stable/catalog_stage.xml
Comment 27 pslechta 2008-12-09 09:30:53 UTC
The patch was not released officially yet (it is tested right now), so using staging version of the patch is your own
risk and it is not recommended!!
Comment 28 tysonite 2008-12-11 15:08:04 UTC
I cannot install update 1 for nb6.5 because of this issue.
Updater always throw this exception while searching for updates.
How to avoid such behaviour and install update 1?
Comment 29 Lukas Hasik 2008-12-11 15:39:16 UTC
tysonite, try to press the Reload Catalog button in Plugin manager. Or if it doesn't help delete whole
nb_user_dir\var\cache\catalogcache\ directory and restart the IDE
Comment 30 dlipin 2008-12-12 12:55:30 UTC
*** Issue 155332 has been marked as a duplicate of this issue. ***
Comment 31 Exceptions Reporter 2009-02-05 10:20:29 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200902050256)
http://statistics.netbeans.org/exceptions/detail.do?id=123646
Comment 32 dlipin 2009-02-13 12:56:25 UTC
marking as INCOMPLETE while what the fresh logs from the latest dailies with more detailed log.
Comment 33 dlipin 2009-02-25 15:22:15 UTC
At the moment of writing this message I experience serious issue with deadlock.netbeans.org that result in those 
IOExceptions. The connection is opened immideately but no bytes are read for some minutes (about 218 seconds) after 
that the connection is closed with normal code. Here is the wget -d log:

wget -d -S http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz
Setting --server-response (serverresponse) to 1
DEBUG output created by Wget 1.11.4 on Windows-MSVC.

--2009-02-25 18:15:31--  http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/
updates.xml.gz
Resolving deadlock.netbeans.org... seconds 0.00, 193.86.76.38
Caching deadlock.netbeans.org => 193.86.76.38
Connecting to deadlock.netbeans.org|193.86.76.38|:80... seconds 0.00, connected.
Created socket 1940.
Releasing 0x009950a8 (new refcount 1).

---request begin---
GET /hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz HTTP/1.0
User-Agent: Wget/1.11.4
Accept: */*
Host: deadlock.netbeans.org
Connection: Keep-Alive

---request end---
HTTP request sent, awaiting response...
---response begin---
HTTP/1.0 200 OK
Connection: keep-alive
Content-Length: 0
Date: Wed, 25 Feb 2009 15:16:50 GMT
Server: lighttpd/1.4.9

---response end---

  HTTP/1.0 200 OK
  Connection: keep-alive
  Content-Length: 0
  Date: Wed, 25 Feb 2009 15:16:50 GMT
  Server: lighttpd/1.4.9
Registered socket 1940 for persistent reuse.
Length: 0
Saving to: `updates.xml.gz'

    [ <=>                                                                                                                                                                     ] 
0           --.-K/s   in 0s

2009-02-25 18:19:08 (0.00 B/s) - `updates.xml.gz' saved [0/0]
Comment 34 Quality Engineering 2009-03-02 20:57:22 UTC
Integrated into 'main-golden', will be available in build *200903021401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c6e1507c0f1e
User: Dmitry Lipin <dlipin@netbeans.org>
Log: Report zero sized/broken downloaded catalog. Hopefully will help to finally fix Issue #150034 and Issue #152010
Comment 35 dlipin 2009-03-06 10:56:12 UTC
*** Issue 159764 has been marked as a duplicate of this issue. ***
Comment 36 dlipin 2009-03-06 14:46:42 UTC
According to 
http://statistics.netbeans.org/exceptions/messageslog?id=170033

Processing URL: http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/
updates.xml.gz
Processing URL: http://updates.netbeans.org/netbeans/updates/dev/uc/final/main/catalog.xml.gz?
unique=NB_JAVA_WEBCOMMON_WEBEE051998700-2bdb-4080-8f17-e6f5b725459d_e7ae5eb7-4e92-4227-81ce-148faa142704
Read 239400 bytes from catalog at http://updates.netbeans.org/netbeans/updates/dev/uc/final/main/catalog.xml.gz?
unique=NB_JAVA_WEBCOMMON_WEBEE051998700-2bdb-4080-8f17-e6f5b725459d_e7ae5eb7-4e92-4227-81ce-148faa142704
Read 1597624 bytes from catalog at http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/
nbbuild/nbms/updates.xml.gz
SEVERE Cannot estabilish input stream for file:/C:/Documents%20and%20Settings/goran/.netbeans/dev/var/cache/
catalogcache/URL_Default_N
java.io.IOException: Not in GZIP format


It is said that 239400 bytes read from http://updates.netbeans.org/netbeans/updates/dev/uc/final/main/catalog.xml.gz.
I`ve checked the URL that the size of that catalog.xml.gz is 62379 and the size of catalog.xml is really 239400 bytes.
So it looks like server wrongly returns pure file instead of the gzipped one. Not sure how to fix that...
The good thing is that deadlock.netbeans.org forks fine - 1597624 is the correct size of the gzipped catalog.
Comment 37 Quality Engineering 2009-03-07 09:49:29 UTC
Integrated into 'main-golden', will be available in build *200903070353* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/cb5ae790fde4
User: Dmitry Lipin <dlipin@netbeans.org>
Log: More logging to identify IOException thrown during catalog parsing (Issue #150034)
Comment 38 goeh 2009-03-08 09:52:23 UTC
Build: NetBeans IDE Dev (Build 200903070353)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Windows XP, 5.1, x86

User Comments: 
Restarted NB as prompted by subversion client installer.
This exception happens quite frequently.

Stacktrace: 
java.io.IOException: Not in GZIP format
        at java.util.zip.GZIPInputStream.readHeader(GZIPInputStream.java:137)
        at java.util.zip.GZIPInputStream.<init>(GZIPInputStream.java:58)
        at java.util.zip.GZIPInputStream.<init>(GZIPInputStream.java:68)
        at org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogParser.getInputSource(AutoupdateCatalogParser.java:180)
        at org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogParser.getUpdateItems(AutoupdateCatalogParser.java:150)
        at org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogProvider.getUpdateItems(AutoupdateCatalogProvider.java:110)
Comment 39 goeh 2009-03-08 09:52:34 UTC
Created attachment 77874 [details]
stacktrace
Comment 40 dlipin 2009-03-10 16:20:37 UTC
finally fixed in core-main#c07047c47ce9
Comment 41 Quality Engineering 2009-03-11 22:50:48 UTC
Integrated into 'main-golden', will be available in build *200903111543* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c07047c47ce9
User: Dmitry Lipin <dlipin@netbeans.org>
Log: Issue #150034 java.io.IOException: Not in GZIP format
Issue #152010 java.io.EOFException at java.util.zip.GZIPInputStream.readUByte
Under certain circumstances the size of catalog.xml.gz is proceeded is downloaded as the catalog.xml file.
Write exception in the log and don`t disturb the user too much.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo