Bug 149232 - NullPointerException at oracle.jdbc.ttc7.TTC7Protocol.describe
NullPointerException at oracle.jdbc.ttc7.TTC7Protocol.describe
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 13:22 UTC by arthurbuliva
Modified: 2009-09-15 14:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (823 bytes, text/plain)
2008-10-06 13:22 UTC, arthurbuliva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description arthurbuliva 2008-10-06 13:22:25 UTC
Build: NetBeans IDE 6.1 (Build 200805300101)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_04-b12
OS: Windows Vista, 6.0, x86

User Comments:
arthurbuliva: View table data in Oracle



Stacktrace: 
java.lang.NullPointerException
        at oracle.jdbc.ttc7.TTC7Protocol.describe(TTC7Protocol.java:772)
        at oracle.jdbc.ttc7.TTC7Protocol.parseExecuteDescribe(TTC7Protocol.java:882)
        at oracle.jdbc.driver.OracleStatement.doExecuteQuery(OracleStatement.java:2599)
        at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:2963)
        at oracle.jdbc.driver.OracleStatement.execute(OracleStatement.java:961)
        at org.netbeans.modules.db.sql.execute.SQLExecuteHelper.execute(SQLExecuteHelper.java:121)
Comment 1 arthurbuliva 2008-10-06 13:22:38 UTC
Created attachment 71199 [details]
stacktrace
Comment 2 David Vancouvering 2008-10-06 21:40:12 UTC
Does this happen every time, or was this a one-time exception?  Are you able to continue your work or is this preventing
you from making progress?

Thanks!
Comment 3 David Vancouvering 2008-10-07 17:42:13 UTC
Arthur says in direct email to me:
Netbeans still works after that even though I have to disconnect then reconnect the database connection in order to make
the sql editor useful again. Generally NetBeans keeps running though
Comment 4 David Vancouvering 2008-10-07 17:43:23 UTC
Hi, Arthur: does this happen a lot or just randomly?  Also, is this a query you have written by hand, or did you just do
View Data?

Thanks.
Comment 5 David Vancouvering 2008-10-09 18:21:33 UTC
Haven't heard back from Arthur, assuming this is a P3
Comment 6 David Vancouvering 2008-11-13 19:42:26 UTC
It would be good to fix this, but may not be able to reproduce.
Comment 7 Jiri Rechtacek 2009-02-10 15:23:41 UTC
Reassigned to new owner.
Comment 8 Jiri Skrivanek 2009-09-15 14:49:12 UTC
Cannot reproduce.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo