Bug 148863 - NullPointerException at org.nbheaven.sqe.codedefects.resultui.action.AbstractRunSingleSQEAction$Processor.execute
NullPointerException at org.nbheaven.sqe.codedefects.resultui.action.Abstract...
Status: RESOLVED FIXED
Product: third-party
Classification: Unclassified
Component: sqe tools
6.x
All All
: P1 (vote)
: TBD
Assigned To: sreimers
sreimers
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 164116 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 15:13 UTC by arkalon
Modified: 2009-10-16 10:03 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.11 KB, text/plain)
2008-10-01 15:14 UTC, arkalon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description arkalon 2008-10-01 15:13:57 UTC
Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05, Java(TM) SE Runtime Environment, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments:
arkalon: Trying to run Findbugs on a J2ME Project

GUEST: I was trying to run Checkstyle as plugin in Netbeans

GUEST: SQE plugin (FindBugs etc) does not work on Java EE projects.

rdelaplante: Right clicked a Maven2 project, SQL -> Run Checkstyle.  Got this exception

arkalon: Trying to run Findbugs on a J2ME Project



Stacktrace: 
java.lang.NullPointerException
        at org.nbheaven.sqe.codedefects.resultui.action.AbstractRunSingleSQEAction$Processor.execute(AbstractRunSingleSQEAction.java:120)
        at org.nbheaven.sqe.codedefects.resultui.action.AbstractRunSingleSQEAction.performAction(AbstractRunSingleSQEAction.java:59)
        at org.openide.util.actions.NodeAction.performAction(NodeAction.java:289)
        at org.openide.util.actions.CallableSystemAction$1.run(CallableSystemAction.java:118)
        at org.netbeans.modules.openide.util.ActionsBridge$ActionRunnable.actionPerformed(ActionsBridge.java:111)
        at org.netbeans.core.ModuleActions.invokeAction(ModuleActions.java:104)
Comment 1 arkalon 2008-10-01 15:14:12 UTC
Created attachment 70972 [details]
stacktrace
Comment 2 Petr Chytil 2008-10-02 08:12:24 UTC
This NPE comes from 3rd party module SQE - please file an issue into their bug tracking system:
https://sqe.dev.java.net/servlets/ProjectIssues
Comment 3 Lukas Hasik 2008-11-23 20:43:40 UTC
reassigning to sqe-tools subcomponent
Comment 4 Exceptions Reporter 2009-08-13 10:48:18 UTC
This issue already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=69694
Comment 5 Exceptions Reporter 2009-09-22 10:45:22 UTC
This issue already has 53 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=69694
Comment 6 Jesse Glick 2009-09-28 17:32:36 UTC
Nothing resembling this class or method present in current SQE sources, presuming fixed.
Comment 7 Jesse Glick 2009-09-28 18:14:24 UTC
*** Issue 164116 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo