Bug 148674 - [65cat] ArrayIndexOutOfBoundsException: 2174
[65cat] ArrayIndexOutOfBoundsException: 2174
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Lexer
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Miloslav Metelka
issues@editor
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 20:16 UTC by goeh
Modified: 2008-10-06 12:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.28 KB, text/plain)
2008-09-29 20:16 UTC, goeh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description goeh 2008-09-29 20:16:30 UTC
Build: NetBeans IDE Dev (Build 200809231435)
VM: Java HotSpot(TM) Client VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: Windows XP, 5.1, x86

User Comments:
goeh: Editing a Grails WebFlow controller.
Double-clicked the word Integer in Integer.valueOf(s) and was about to replace Integer with Long. First I got ArrayIndexOutOfBoundsException then a half second later I got NullPointerException.



Stacktrace: 
java.lang.ArrayIndexOutOfBoundsException: 2174
        at org.netbeans.lib.lexer.LAState$LargeState.state(LAState.java:408)
        at org.netbeans.lib.lexer.inc.IncTokenList.state(IncTokenList.java:246)
        at org.netbeans.lib.lexer.inc.IncTokenList.replaceTokens(IncTokenList.java:353)
        at org.netbeans.lib.lexer.inc.TokenListUpdater.updateRegular(TokenListUpdater.java:279)
        at org.netbeans.lib.lexer.inc.TokenHierarchyUpdate$UpdateItem.update(TokenHierarchyUpdate.java:346)
        at org.netbeans.lib.lexer.inc.TokenHierarchyUpdate.processLevelInfos(TokenHierarchyUpdate.java:221)
Comment 1 goeh 2008-09-29 20:16:42 UTC
Created attachment 70832 [details]
stacktrace
Comment 2 Miloslav Metelka 2008-10-06 11:56:42 UTC
This should be eliminated by fix of issue 144258.
Comment 3 Miloslav Metelka 2008-10-06 12:01:16 UTC
Since issue 144258 was integrated almost at the time like your testing build was created I would like to ask you to get
a newer dev build and if you would be able to reproduce the problem there please reopen the issue. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo