Bug 148193 - org.netbeans.api.db.explorer.DatabaseException: java.sql.SQLException: Can't create/write to file '/tmp/rm153204/#sql_2d68_0.MYI' (Errcode: 13)
org.netbeans.api.db.explorer.DatabaseException: java.sql.SQLException: Can't ...
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 12:12 UTC by Roman Mostyka
Modified: 2009-10-23 12:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.12 KB, text/plain)
2009-02-11 01:34 UTC, saltzmanjoelh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-09-24 12:12:17 UTC
Build: NetBeans IDE Dev (Build 080924)
VM: Java HotSpot(TM) Client VM, 1.5.0_13-121, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_13-b05-241
OS: Mac OS X, 10.4.11, i386

User comments:
1. Add MySQL server.
2. Create "travel" DB and connect to it.
3. Expand "travel" > Tables > "carrental".

Result: DatabaseException arises.
I reproduced this issue on Mac OS X.
STACKTRACE: (first 10 lines)
org.netbeans.api.db.explorer.DatabaseException: java.sql.SQLException: Can't create/write to file
'/tmp/rm153204/#sql_2d68_0.MYI' (Errcode: 13)
        at org.netbeans.modules.db.explorer.infos.TableNodeInfo.initChildren(TableNodeInfo.java:172)
        at org.netbeans.modules.db.explorer.infos.TableNodeInfo.initChildren(TableNodeInfo.java:78)
        at org.netbeans.modules.db.explorer.infos.DatabaseNodeInfo.loadChildren(DatabaseNodeInfo.java:742)
        at org.netbeans.modules.db.explorer.infos.DatabaseNodeInfo.getChildren(DatabaseNodeInfo.java:730)
        at org.netbeans.modules.db.explorer.nodes.DatabaseNode$DatabaseNodeChildFactory.createKeys(DatabaseNode.java:382)
        at org.openide.nodes.AsynchChildren.run(AsynchChildren.java:147)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:572)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:997)
Comment 1 David Vancouvering 2008-09-24 19:49:11 UTC
If you click on JavaDB->Properties in the Services/Databases tab, what do you see for the database directory?
Comment 2 Roman Mostyka 2008-09-25 09:17:17 UTC
David, I have this problem with MySQL. Everything is fine with Java DB, I tried.
But before I didn't have this problem with the same MySQL server.
Comment 3 Roman Mostyka 2008-09-25 09:20:08 UTC
By the way, everything was fine before, so it is a regression.
Comment 4 John Baker 2008-10-02 06:58:09 UTC
Please check /tmp  to see if the user has permissions to write to /tmp 

If the user has permissions then make sure /tmp has sufficient space.
Comment 5 Roman Mostyka 2008-10-02 14:27:09 UTC
The problem is that I didn't see such problem before.
About permissions: I don't have rights to write in this directory, but I built IDE from fresh sources and have different
login, why IDE tries to write in this directory? And why I easily can do the same actions for the rest supported DBs
(Java DB, Oracle, PostgreSQL).
And moreover, I have the same problem on Windows XP.
Comment 6 Jiri Rechtacek 2009-02-10 15:48:35 UTC
Reassigned to new owner.
Comment 7 saltzmanjoelh 2009-02-11 01:34:11 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
OS: Mac OS X, 10.5.6, i386

User Comments: 
update just ran, trying to restart

Stacktrace: 
org.netbeans.api.db.explorer.DatabaseException: java.sql.SQLException: Can't create/write to file '/var/folders/v5/v5pVdXQPFDqXTDr+YMG-tE+++TI/-Tmp-/#sql_9b81_0.MYI' (Errcode: 13)
        at org.netbeans.modules.db.explorer.infos.TableNodeInfo.initChildren(TableNodeInfo.java:172)
        at org.netbeans.modules.db.explorer.infos.TableNodeInfo.initChildren(TableNodeInfo.java:78)
        at org.netbeans.modules.db.explorer.infos.DatabaseNodeInfo.loadChildren(DatabaseNodeInfo.java:742)
        at org.netbeans.modules.db.explorer.infos.DatabaseNodeInfo.getChildren(DatabaseNodeInfo.java:730)
        at org.netbeans.modules.db.explorer.nodes.DatabaseNode$DatabaseNodeChildFactory.createKeys(DatabaseNode.java:382)
        at org.openide.nodes.AsynchChildren.run(AsynchChildren.java:147)
Comment 8 saltzmanjoelh 2009-02-11 01:34:16 UTC
Created attachment 76826 [details]
stacktrace
Comment 9 Jiri Rechtacek 2009-07-01 07:44:45 UTC
NB6.7 was released already - http://www.netbeans.org/community/releases/67/
Postpone fixing this issue on the next release.
Comment 10 Jiri Rechtacek 2009-10-23 12:09:18 UTC
It's not reproducible I guess.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo