Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 148174 - org.netbeans.modules.glassfish classes are loaded on NetBeans startup with LimeWire project
org.netbeans.modules.glassfish classes are loaded on NetBeans startup with Li...
Status: VERIFIED DUPLICATE of bug 148177
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Petr Hejl
issues@serverplugins
http://wiki.netbeans.org/FitnessViaWh...
: PERFORMANCE, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 10:02 UTC by Alexander Kouznetsov
Modified: 2008-10-09 13:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stacktraces (27.56 KB, text/plain)
2008-09-24 10:03 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-09-24 10:02:52 UTC
Performance test reports that the following classes are loaded on NetBeans startup with LimeWare project:

    org.netbeans.modules.glassfish.common.GlassfishInstanceProvider
    org.netbeans.modules.glassfish.javaee.Hk2DeploymentFactory
    org.netbeans.modules.glassfish.javaee.Hk2OptionalFactory
    org.netbeans.modules.glassfish.spi.ServerUtilities

Please don't load these classes unless they are really necessary.
Comment 1 Alexander Kouznetsov 2008-09-24 10:03:15 UTC
Created attachment 70417 [details]
Stacktraces
Comment 2 _ pcw 2008-09-25 06:45:41 UTC
Initialization of the GlassFish server registry is already lazy (to the extreme).  These classes are being loaded
because j2eeserver module is explicitly requesting server registry initialization.

--> j2eeserver for evaluation on whether this is necessary in this circumstance.
Comment 3 Petr Hejl 2008-10-08 13:19:40 UTC
The cause is the same as for issue 148177.

*** This issue has been marked as a duplicate of 148177 ***
Comment 4 Alexander Kouznetsov 2008-10-09 13:35:13 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo