Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 147465 - IDE got stuck
IDE got stuck
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Nodes
6.x
All All
: P2 (vote)
: 6.x
Assigned To: t_h
issues@platform
:
: 147476 147506 147526 147667 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 10:43 UTC by Alexander Kouznetsov
Modified: 2008-12-22 13:23 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (12.83 KB, text/plain)
2008-09-17 10:44 UTC, Alexander Kouznetsov
Details
Another thread dump after several hours of IDE being frozen (12.72 KB, text/plain)
2008-09-17 10:45 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-09-17 10:43:14 UTC
IDE Dev 080915

IDE got stuck when I was trying to edit my java files using code completion and other java editor features while
compiling of classes was in progress.

See attached threaddump.
Comment 1 Alexander Kouznetsov 2008-09-17 10:44:04 UTC
Created attachment 70020 [details]
Thread dump
Comment 2 Alexander Kouznetsov 2008-09-17 10:45:54 UTC
Created attachment 70021 [details]
Another thread dump after several hours of IDE being frozen
Comment 3 Tomas Danek 2008-09-17 11:43:53 UTC
seems to be in openide/nodes
Comment 4 Jaroslav Tulach 2008-09-17 15:27:10 UTC
*** Issue 147476 has been marked as a duplicate of this issue. ***
Comment 5 Lukas Hasik 2008-09-17 16:42:37 UTC
*** Issue 147506 has been marked as a duplicate of this issue. ***
Comment 6 t_h 2008-09-17 20:07:32 UTC
*** Issue 147526 has been marked as a duplicate of this issue. ***
Comment 7 t_h 2008-09-18 14:28:28 UTC
e7c2ef4255e1
Comment 8 Lukas Hasik 2008-09-19 09:29:00 UTC
*** Issue 147667 has been marked as a duplicate of this issue. ***
Comment 9 Quality Engineering 2008-09-19 17:32:43 UTC
Integrated into 'main-golden', will be available in build *200809191401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e7c2ef4255e1
User: Tomas Holy <t_h@netbeans.org>
Log: #147465: IDE got stuck


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo