Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 146833 - XSD rename appears to be case-insensitive
XSD rename appears to be case-insensitive
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Refactoring
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Sonali Kochar
issues@xml
61fixes4-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 18:42 UTC by andyloh
Modified: 2008-10-15 21:52 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andyloh 2008-09-10 18:42:52 UTC
Observed with GlassFishESB 9/9 build.  I has incorrectly entered the name of an XML Schema as "HelloXSLtIncoming" (note
the lowercase "t").  This caused problems when I entered the name correctly ("HelloXSLTIncoming") in the XSL file.  When
I tried to rename the XSD file to the correct name (with capital "T"), an error appeared stating "Error: New name should
be unique."  Since the code in the XSL is case-sensitive, I would expect to be able to rename the XSD using the proper
case for each letter.
Comment 1 Vitaly Bychkov 2008-09-11 10:56:06 UTC
This issue is reproducable in Netbeans 6.5 (Build 20080831125309) too.
Comment 2 Sergey Lunegov 2008-09-11 12:47:38 UTC
Sam, Sonali, would you please look at this ?
Comment 3 Sonali Kochar 2008-09-11 22:00:23 UTC
changeset 17bc44c4fb35 in main
details: http://hg.netbeans.org/main?cmd=changeset;node=17bc44c4fb35
Comment 4 Quality Engineering 2008-09-12 06:07:55 UTC
Integrated into 'main-golden', will be available in build *200809120201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1f3425e01f5d
User: sonali@netbeans.org
Log: Fix for issue#146833 XSD rename appears to be case-insensitive
Comment 5 _ alexpetrov 2008-09-24 15:48:20 UTC
Verified on:
Product Version: NetBeans IDE Dev (Build 080919)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b02
System: Windows XP version 5.1 running on x86
Comment 7 andyloh 2008-10-07 01:49:44 UTC
Tested with NetBeans 6.1 patch 4 (2008-10-03_19-45-23) on Windows Vista.  When refactoring/renaming an XSD, I am now
able to change the case of the letters in the name without getting the error message that the name must be unique. 
However, I found a related problem in the new XML Schema wizard, where the name entered for a new XSD is still
case-insensitive (see issue 149304).  


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo