Bug 146077 - "Create fixed watch" from expression evaluator does nothing
"Create fixed watch" from expression evaluator does nothing
Status: VERIFIED DUPLICATE of bug 146496
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 17:52 UTC by Petr Cyhelsky
Modified: 2008-09-14 19:12 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2008-09-03 17:52:38 UTC
Product Version: NetBeans IDE Dev (Build 200809021401)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b14
System: Windows Vista version 6.0 running on x86; Cp1250; cs_CZ (nb)

Observed: The popup menu item Create fixed watch on just evaluated item in expression evaluator (which is like
mini-watch view) does nothing.

Expected: It should either really create fixed watch or the option shouldn't even be there(or at least it should be
disabled).

Steps to reproduce: have some java application -> place some breakpoint -> debug the project -> invoke Debug|Evaluate
expression -> write some valid object into the textfield(for example this) -> press evaluate button -> invoke popup menu
on the newly created element (this) in pane under the textfield -> invoke "create fixed watch" -> nothing happens
Comment 1 Martin Entlicher 2008-09-14 11:15:21 UTC
Reproduced.
Comment 2 Martin Entlicher 2008-09-14 11:27:31 UTC
This does not work for the same reason why "Go to Source" does not work.

*** This issue has been marked as a duplicate of 146496 ***
Comment 3 Petr Cyhelsky 2008-09-14 19:12:03 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo