Bug 146036 - Support for CodeIgniter framework
Support for CodeIgniter framework
Status: RESOLVED WONTFIX
Product: php
Classification: Unclassified
Component: Project
7.4
All All
: P1 with 121 votes (vote)
: 8.0
Assigned To: Tomas Mysik
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 13:26 UTC by Petr Pisl
Modified: 2014-03-19 09:39 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2008-09-03 13:26:43 UTC
Build a support for CodeIgniter PHP Web Application Framework.

See: http://codeigniter.com/
Comment 1 Judzhin 2010-03-18 16:36:17 UTC
Build a support for CodeIgniter PHP Web Application Framework

See: http://codeigniter.com/
Comment 2 Petr Jiricka 2010-03-23 11:49:59 UTC
Here is an interesting related blog (a bit old):

http://www.mybelovedphp.com/2009/01/23/netbeans-revisited-code-completion-for-code-igniter/
Comment 3 Cormo 2010-03-23 14:36:09 UTC
(In reply to comment #2)
> Here is an interesting related blog (a bit old):
> 
> http://www.mybelovedphp.com/2009/01/23/netbeans-revisited-code-completion-for-code-igniter/

I already followed the instructions in the url you submited. The issue sent was produced even using the @property before de class declaration.
Comment 4 jaygridley 2010-06-14 15:59:14 UTC
Build a support for CodeIgniter PHP Web Application Framework.

See: http://codeigniter.com/
Comment 5 tschundeee 2010-07-13 11:32:41 UTC
get started with code completion for codeigniter.com

interesting workaround:
 http://masnun.com/blog/2010/06/16/codeigniter-code-completion-with-the-netbeans-ide-for-php/
Comment 6 chris4beta 2010-10-03 22:31:24 UTC
Recently passed the 2-year mark for this suggestion. Is this ever going to happen?
Comment 7 Petr Pisl 2010-10-04 08:46:29 UTC
Unfortunately  I don't know about a plan to provide the support in the next release. On the other hand the plan is not still final and the plan is still open.
Comment 8 chris4beta 2010-10-11 19:50:21 UTC
I see that you are adding CakePHP support, and I'd say that CodeIgniter is as popular as Cake - as well as being somewhat similar from an MVC perspective? Maybe since you are already going through the trouble of adding Cake, you can go ahead and add CodeIgniter at the same time, and then Netbeans will have support for all the big PHP frameworks out there.
Comment 9 Cormo 2010-10-12 08:53:47 UTC
(In reply to comment #8)
> I see that you are adding CakePHP support, and I'd say that CodeIgniter is as
> popular as Cake - as well as being somewhat similar from an MVC perspective?
> Maybe since you are already going through the trouble of adding Cake, you can
> go ahead and add CodeIgniter at the same time, and then Netbeans will have
> support for all the big PHP frameworks out there.

I have to totally agree to this comment. Adding CodeIgniter to the list of supported frameworks would be greatly appreciated.
Comment 10 BaRzO 2010-10-12 13:25:38 UTC
I agree too.
Pls add support for codeigniter.
Comment 11 aderik 2010-11-04 10:05:45 UTC
Support for CodeIgniter please
Comment 12 dark4832 2010-11-04 10:52:46 UTC
Please, add Codeigniter support, it'll be greatly appreciated, CI is one of most popular frameworks, and there still no any good IDE with good build-in support for it. I tried Codelobster with CI plug-in, and PhpDesigner - but they far-far behind NetBeans.
Comment 13 roma96 2010-11-06 10:20:54 UTC
Build a support for CodeIgniter PHP Web Application Framework.
Comment 14 skergetd 2010-11-06 11:18:42 UTC
CI support in Netbeans would really rock! Please do something about it...
Comment 15 brbrbr 2010-12-08 00:38:53 UTC
It would be nice if u'll work on CI support for NetBeans. I'm new in CI so I went sad when didnt find CI support for my favourite IDE :(
Comment 16 hoangjoom 2010-12-08 18:28:04 UTC
Pls add support for codeigniter.
Comment 17 Petr Pisl 2010-12-09 12:25:33 UTC
I would like to add the support as well. The problem what I have now is the time. Now we are at finishing phase of NB 7.0, so hope that there will be a little time to create at least some basic support for next release.

If someone from community could work on it, I can advice and help a little.
Comment 18 marshallmutiso 2010-12-25 02:42:33 UTC
Please add support for this very lightweight very nice framework
http://codeigniter.com/
Comment 19 spec 2010-12-26 23:21:04 UTC
Pls, add code-igniter support
Comment 20 skergetd 2011-04-24 14:15:46 UTC
Anything new in NB7.0 for CodeIgniter?
Comment 21 Queops 2012-01-14 02:51:53 UTC
Amazing and sad how this wasn't implemented yet, one of the great PHP frameworks.
Comment 22 awgreenarrow08 2012-01-24 14:16:20 UTC
Very surprising that 7.1 still doesn't contain CodeIgniter support. This must be one of the most popular frameworks for PHP Web Application development! There are many conversations on LinkedIn where professional PHP developers discuss their favorite IDEs and frameworks, and most say that Netbeans is the favorite IDE and CodeIgniter is the favorite framework. 

Please build a support for CodeIgniter PHP Web Application Framework!

See: http://codeigniter.com/
Comment 23 outofcontrol 2012-01-24 14:19:32 UTC
As NetBeans is my favourite IDE, I am curious what sort of support people are looking for. In NetBeans I have had CI auto complete for months now based on some of the generally available tutorials. 

Is there additional support that I am missing out on? Not arguing, just trying to understand more.
Comment 24 macodev 2012-01-26 13:24:13 UTC
Please add support for Codeigniter framework like already is Zend, Symfony and Smarty!

http://codeigniter.com
Comment 25 stooby 2012-01-26 14:18:22 UTC
I would also very much like to see this implemented, I imagine not too difficult to include ?
Comment 26 clebersoncs 2012-01-26 19:53:09 UTC
I agree too.
Please add support for codeigniter.
Comment 27 ir1keren 2012-01-27 21:29:20 UTC
Still no CodeIgniter and Android support?
that's pathetic.
Currently,in Indonesia,CodeIgniter is most famous framework :D
Comment 28 Isht43 2012-03-27 13:18:02 UTC
(In reply to comment #27)
> Still no CodeIgniter and Android support?
> that's pathetic.
> Currently,in Indonesia,CodeIgniter is most famous framework :D

Totally agree,
I think NetBeans should include support for CodeIgniter
I'd would appreciate that.
Comment 29 pcpbslack 2012-03-28 11:44:46 UTC
I love NetBeans and CodeIgniter framework.

I found a CI plugin for NetBeans (7.0.1 && 7.1.1) here: http://kenai.com/projects/nbphpci/pages/NBInstall

I was not able to review the functionality but I can confirm that it works (is able to detect a CI project).

I also found a small bug, but this is another discussion.

I hope this helps someone!!!
Comment 30 adeelx 2012-06-12 08:32:24 UTC
Please include CI Support!!
Comment 31 php_ci 2012-06-28 13:21:48 UTC
(In reply to comment #17)
> I would like to add the support as well. The problem what I have now is the
> time. Now we are at finishing phase of NB 7.0, so hope that there will be a
> little time to create at least some basic support for next release.
> 
> If someone from community could work on it, I can advice and help a little.


I would like to highlight the comment of pcpbslack@netbeans.org . There is a working CI plugin for NetBeans (7.0.1 && 7.1.1) at http://kenai.com/projects/nbphpci/pages/Home

Why not integrate that plugin to Netbeans officially? IMHO It would be better than proceeding with the current parallel development in another site. (The reason given by author in forums for not publishing was that his plugin currently supports only a few features)

Hope someone assists him. It would be a shame if that project becomes abandoned in future, and here people complain about non support of CI in Netbeans.
Comment 32 Cormo 2012-06-28 13:35:41 UTC
I could not agree more with this comment.
Comment 33 Tomas Mysik 2012-06-28 16:15:22 UTC
(In reply to comment #31)
> Why not integrate that plugin to Netbeans officially?

Correct me if I am wrong but it seems to me that the plugin provides only integration with the new project wizard - or am I wrong? Is the plugin _really_ good enough for developers using CI framework? Isn't really any feature from the "Plan" section [1] important?

> Hope someone assists him. It would be a shame if that project becomes abandoned
> in future, and here people complain about non support of CI in Netbeans.

Of course, we would like to provide support for (not only) this framework but - as always and as everywhere - it is about resources, sorry. Of course, if the author needs anything to be done on NetBeans' side, I will be more than happy to help him, if possible.

Thanks for understanding.
[1] http://kenai.com/projects/nbphpci/pages/Home
Comment 34 Petr Jiricka 2012-07-08 13:17:49 UTC
I'd say if people find the plugin helpful even if the functionality is limited, why not publish it on plugins.netbeans.org, so users can find it more easily? Ideally the plugin author himself should do this.
Comment 35 Carmageddon 2012-11-05 21:47:17 UTC
This bug report was hard to find, last time I googled the same issue 6 months ago I did not come across this.


I am certain a lot more people than those who voted, want to see NetBeans support for CodeIgniter.

Is it really so complex feature that it wasn't done for years?
Comment 36 cvioletti 2013-01-28 19:36:00 UTC
+1 for CodeIgniter support.
Comment 37 gobeksalata 2013-02-07 19:44:03 UTC
CI is widely used and very popular PHP Framework. Please add support i am really frasturated to enter each custom module's name to autocomple.php... this should be rally easy to integrate Come on guys.
Comment 38 phpkode 2013-02-18 11:58:08 UTC
(In reply to comment #33)
> (In reply to comment #31)
> > Why not integrate that plugin to Netbeans officially?
> 
> Correct me if I am wrong but it seems to me that the plugin provides only
> integration with the new project wizard - or am I wrong? Is the plugin _really_
> good enough for developers using CI framework? Isn't really any feature from
> the "Plan" section [1] important?
> 
> > Hope someone assists him. It would be a shame if that project becomes abandoned
> > in future, and here people complain about non support of CI in Netbeans.
> 
> Of course, we would like to provide support for (not only) this framework but -
> as always and as everywhere - it is about resources, sorry. Of course, if the
> author needs anything to be done on NetBeans' side, I will be more than happy
> to help him, if possible.
> 
> Thanks for understanding.
> [1] http://kenai.com/projects/nbphpci/pages/Home


The plugin gives auto complete functionality. You can check the screen shot attached

http://i45.tinypic.com/n1xdnc.jpg
Comment 39 jankubeug 2013-02-22 10:55:48 UTC
Codeigniter Community is still growing fast. Please add CI support. Thanks!
Comment 40 Carmageddon 2013-03-01 23:59:40 UTC
What does the latest modification to "Next" means?
That it is going to be added in the next stable release? or which? is there a rough ETA for this?
Comment 41 Tomas Mysik 2013-03-04 07:23:21 UTC
(In reply to comment #40)
> What does the latest modification to "Next" means?
> That it is going to be added in the next stable release? or which? is there a
> rough ETA for this?

Basically, unfortunately we (NetBeans developers) do not have enough resources to provide support for the CI framework. In such case, there are 2 possibilities:
(a) use an existing support provided by our community [1] (see previous comments in this issue);
(b) become a member of NB PHP Community Council [2] and help to implement this support.

Thanks.
[1] http://kenai.com/projects/nbphpci/pages/NBInstall
[2] https://blogs.oracle.com/netbeansphp/entry/netbeans_php_community_council
Comment 42 theshowmecanuck 2013-03-04 14:06:03 UTC
Or 3,
    people who use one of the top two or three largest PHP frameworks (code igniter) don't use Net Beans. Some would say code igniter is the top.

Thanks.

http://webcoderpro.com/blog/top-5-most-popular-php-frameworks-of-2012/
http://www.phpframeworks.com/top-10-php-frameworks/
Comment 43 erinskabbash 2013-03-07 18:32:35 UTC
+1 add support for codeigniter!
Comment 44 nmabhinandan 2013-12-04 13:17:53 UTC
Adding CodeIgniter and Laravel support will be appreciated.
Comment 45 Tomas Mysik 2013-12-04 13:22:16 UTC
Since there is a plugin provided by our community [1], I will close this issue.

Thanks.
[1] https://github.com/nbphpcouncil/nb-ci-plugin
Comment 46 boxer 2014-03-19 09:35:27 UTC
Build a support for CodeIgniter PHP Web Application Framework.
Comment 47 boxer 2014-03-19 09:37:32 UTC
Build a support for CodeIgniter PHP Web Application Framework.
Comment 48 Tomas Mysik 2014-03-19 09:39:40 UTC
Please, do not reopen this issue, there is no reason for it (see my comment #45).

Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo