Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 146028 - Support for Zend Framework
Support for Zend Framework
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Project
6.x
All All
: P1 with 115 votes (vote)
: 6.x
Assigned To: Tomas Mysik
issues@php
:
: 153898 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 12:24 UTC by Petr Pisl
Modified: 2010-01-09 05:39 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2008-09-03 12:24:28 UTC
Create a support for developing PHP application based on Zend Framework.

See: http://framework.zend.com/
Comment 1 loic_frering 2008-09-04 09:27:48 UTC
It would be great, in the future, to be able to run commands of the new Zend Framework CLI from Netbeans. Just as well
as the rails rake tasks and rails generator.
Comment 2 tjercus 2008-09-05 07:57:02 UTC
What I would like to see are wizards (and/or context menu options) to:
- create a new controller with actions and templates (Zend MVC)
- create the skeleton directory structure, bootstrap file and IndexController, ErrorController (see: Zend_Tool)
- create a simple CRUD controller and views based on a POPO. Create the Views using generated templates or Zend_Form 
code. Persistence is, in my humble opinion, not necessary in this wizard.

any of these 'productivity wizards' would be very nice.
Comment 3 pcdinh 2008-09-06 20:21:08 UTC
I know it is hard but it is great to see some sort of code completion support in template files. In Zend Framework or
Symfony or CakePHP or any PHP MVC-push style framework, you can find a lot of the code like $this->varname in template
files where $this means the instance of the View class where the template file belongs to. I think that if Netbeans
supports a wizard to allow developers to manually map a given template file (*.tpl.php or *.thtml) to its host View
classes to resolve $this scope, it is extremely useful.
Comment 4 loic_frering 2008-09-06 22:15:14 UTC
I completely agree with pcdinh on this point and would be glad to see this feature implemented in NetBeans :)
Comment 5 tprochazka 2008-09-22 09:42:37 UTC
to pcdinh: I think, that for it is very important issue #146248 (#147023). This give possibility to autocomplete in 
forech cycle, view templates, etc. I think, that this is more important, that direct support of one framework. Because 
this is usefull for all frameworks.
Comment 6 Tomas Mysik 2008-11-26 09:05:39 UTC
*** Issue 153898 has been marked as a duplicate of this issue. ***
Comment 7 radalin 2009-07-04 09:52:58 UTC
I would like to note that, with the new Zend_Tool and Zend_Application libraries it will be pretty easy to create 
"wizards" as they are already created by the framework. The only thing required to do in Netbeans is to create a gui 
which will call that components, just like it's done in ruby on rails.
Comment 8 zeronex 2009-07-06 20:59:56 UTC
Getting the code assistant to work is 5 stars i.e. by defining which call this view inherits, alot feature to drag and
drop database fields with getter and setter and comments.
Comment 9 rockaut 2009-07-13 15:06:31 UTC
As noted in the "Symphony..." Blogpost it would be nice to see Zend Framework also supported, since there is command
line support since some time.
See Zend_Tool in docs for info.
Comment 10 radalin 2009-07-13 22:29:33 UTC
Zend has already released a beta version of their new Zend Studio (version 7.0) for Eclipse IDEs and it includes an 
integration with Zend Framework as "wizards" (right click on the project, select new, select zend framework, select 
controller or something like this.). I'm not sure if this part of the code is shared with others (part of the PDT 
environment for Eclipse) but it can be a good start and a good example when trying to make the integration.

You might check out the manual for details: http://files.zend.com/help/Zend-Studio-7/zend-studio-7.htm 
Comment 11 chetzoff 2009-08-20 15:48:38 UTC
Is there any activity over this issue? Any results? Will this improovement be impelemented in the next version?
Comment 12 maghiel 2009-10-28 02:57:07 UTC
So much silence over this request, yet so many votes! 
Symfony has been added but isnt ZF more important?
You would make my life a lot easier!
Comment 13 Tomas Mysik 2009-10-29 09:39:54 UTC
> So much silence over this request, yet so many votes! 
> Symfony has been added but isnt ZF more important?

The chances are the same for all the frameworks and Symfony has (much) more votes. ZF could be added for the
next release, we will see what the plans will be.

Thanks.
Comment 14 jozefh 2009-10-29 10:07:43 UTC
> "The chances are the same for all the frameworks"
1. Democracy is nice, but to popularize Netbeans PHP around the PHP community you should consider the marketing aspect
of IDE features.
2. IMHO only few visitors of this bugtracker want to create account to be able to vote. Majority of visitors only read
bugtracker if they have problems with IDE. IMO it is not good idea to use a bugtracker instead of poll or survey tool.
Consider to put a poll on main web site http://www.netbeans.org/features/php/index.html because this is the 1-st page
when somebody looks for information about Netbeans PHP.
Comment 15 rockaut 2009-10-29 10:17:27 UTC
I agree with jozefh. Bug tracker isn't the best tool to decide how many people want ZF supportet.
Beside i have to say, that many people working with ZF are using Zend Studio or Eclipse PDT cause it's "advertised" on
the zend pages. But there are growing numbers of users - like me ;) - wich don't like to pay for Studio or just don't
like the bulky Eclipse.
Comment 16 Petr Pisl 2009-10-29 11:00:16 UTC
These issues were entered for the voting, which was published more than your ago.
http://blogs.sun.com/netbeansphp/entry/cake_php_symfony_prado_zend. The issues are still active and main purpose is that
people can write here suggestion, how such support should work, which features should be available etc. 
Comment 17 adlermedrado 2009-11-01 13:39:37 UTC
If Netbeans support for PHP with Zend Framework become true it will be great! 
Comment 18 sergabrod 2009-11-08 19:53:16 UTC
support for Zend Framework would be great!! Because 
this is usefull for all developers.
Comment 19 Framercy 2009-11-27 20:28:43 UTC
Support for view helpers (e.g. partials, formelements ...) in view scripts and maybe templates would be very nice...
Comment 20 Framercy 2009-11-27 20:41:03 UTC
(In reply to comment #19)
> Support for view helpers (e.g. partials, formelements ...) in view scripts and
> maybe templates would be very nice...


Sorry only in .tpl files.

View scripts are workin actually but IDE assistance takes some time...
Comment 21 Tomas Mysik 2010-01-06 05:27:42 UTC
Zend framework now supported in trunk.
Comment 22 sbalbalosa 2010-01-09 04:16:51 UTC
I would like to see zend framework code completion and documentation support. This is just to make it standout, I also want to see Code Generator for database Zend_Db_Table, Zend_Form and other components out there that is essential to a zf application.
Comment 23 Tomas Mysik 2010-01-09 05:39:16 UTC
(In reply to comment #22)
> I would like to see zend framework code completion and documentation support.
> This is just to make it standout, I also want to see Code Generator for
> database Zend_Db_Table, Zend_Form and other components out there that is
> essential to a zf application.

Please, file an enhancement for each functionality you would like to see (with description) for better tracking. Do not reopen this issue, ZF is considered as supported now (its support is similar to the Symfony one).

Thanks a lot.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo