Bug 145304 - Unusable after project properties
Unusable after project properties
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Project
6.x
PC Windows Vista
: P2 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 14:41 UTC by gigitrix
Modified: 2008-09-18 05:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot of the window. You can see the open modules (163.76 KB, image/png)
2008-08-27 14:49 UTC, gigitrix
Details
Another screenshot (165.07 KB, image/png)
2008-08-27 14:53 UTC, gigitrix
Details
I can resize the window, I just can't close it! (150.00 KB, image/png)
2008-08-27 14:53 UTC, gigitrix
Details
Partial Stack Trace (Windows cut it off) (19.31 KB, text/plain)
2008-08-28 15:22 UTC, gigitrix
Details
Screenshot of bug 2 (189.75 KB, text/plain)
2008-08-28 15:26 UTC, gigitrix
Details
Screenshot of bug 2 with window moved (207.47 KB, text/plain)
2008-08-28 15:28 UTC, gigitrix
Details
StackTrace->Tools->Dump All (32.63 KB, text/plain)
2008-08-28 15:59 UTC, gigitrix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gigitrix 2008-08-27 14:41:49 UTC
First of all, this is my first NB bug report so I will probably get the Component and Subcomponent wrong.

After editing the project properties of a Java project in Netbeans 6.5 (Specifically the JavaDoc options) a small window
appeared saying "Saving Project data". This normally flashes on and then goes away but it appears that this small window
has crashed: It has only the framework around it and the contents of the window are exactly the same as the things
behind it, even when you move. The cross icon does not work, and there is no way to access anything behind it as the
dialog has priority. I will End the process and see if I can reproduce the bug, but first I will post a few screenshots
of the bug for more information if you need it, email me gigitrix.gigitrix@com (swap .@).
Comment 1 gigitrix 2008-08-27 14:49:37 UTC
Created attachment 68449 [details]
Screenshot of the window. You can see the open modules
Comment 2 gigitrix 2008-08-27 14:53:01 UTC
Created attachment 68450 [details]
Another screenshot
Comment 3 gigitrix 2008-08-27 14:53:50 UTC
Created attachment 68451 [details]
I can resize the window, I just can't close it!
Comment 4 gigitrix 2008-08-27 14:58:45 UTC
I'd just like to point out that this is pretty high priority since ironically there is no way to save during the
supposed "Saving project data" process. I cannot reproduce it though: may just be a one time quirk. Since I cannot
reproduce, I have put it on P2.
Comment 5 Lukas Hasik 2008-08-27 15:32:46 UTC
could you try to take a thread dump? It looks that the IDe is frozen. http://wiki.netbeans.org/GenerateThreadDump
Comment 6 gigitrix 2008-08-27 17:34:09 UTC
Well if the issue ever repeats I will, but as of now I cannot reproduce it. Will be back with a Thread dump if it
happens again. If not, just close the ticket: obviously just a blip!
Comment 7 gigitrix 2008-08-28 15:20:01 UTC
Well I don't know if it's a related issue but something else happened. Firstly a project I've been using for ages
suddenly had some issues in jnlp-impl.xml. I haven't touched this file but it gave errors on lines 61 and 385. I then
opened it up, and tried to isolate the problem. Couldn't see it (I know you aren't supposed to mess with it anyway) so I
left it as it was. I tried a Clean and Build and got a dialog asking me if I wanted to regenerate the file. I clicked
this and the app froze (see new attachments.) I managed to get a Thread dump this time but the top of it appears to be
truncated by M$Vista (attached). I still have the app open so I am going to try and get VisualVM as detailed on that
wiki page.


I do not know if this is the same or separate issue, but since it is on "Saving Project Data" again I'm guessing it is.
Comment 8 gigitrix 2008-08-28 15:22:49 UTC
Created attachment 68535 [details]
Partial Stack Trace (Windows cut it off)
Comment 9 gigitrix 2008-08-28 15:26:15 UTC
Created attachment 68537 [details]
Screenshot of bug 2
Comment 10 gigitrix 2008-08-28 15:28:15 UTC
Created attachment 68538 [details]
Screenshot of bug 2 with window moved
Comment 11 gigitrix 2008-08-28 15:59:06 UTC
Created attachment 68541 [details]
StackTrace->Tools->Dump All
Comment 12 Milan Kubec 2008-09-11 15:06:26 UTC
Reassigning to Jarda for evaluation or at least explanation of wait() magic in DialogDisplayerImpl. Thanks.
Comment 13 Jaroslav Tulach 2008-09-15 16:30:31 UTC
The DialogDisplayerImpl is not responsible for anything, it runs quite fine, if following line is executed:
"at org.netbeans.core.windows.services.DialogDisplayerImpl$1AWTQuery.showDialog(DialogDisplayerImpl.java:231)"
then there is no deadlock caused by the displaying infrastructure. 

Imho, the deadlock is caused by 
org.netbeans.modules.java.j2seproject.ui.customizer.J2SEProjectProperties.showModifiedMessage(J2SEProjectProperties.java:620)
blocking while holding ProjectManager.mutex() and waiting for result of a task posted to AWT thread.

Jesse should probably define and document what is more priviledged: PM.mutex() or AWT thread? Can AWT code access 
PM.mutex()? Can someone holding PM.mutex() deal with AWT Tree Lock?
Comment 14 Jesse Glick 2008-09-15 17:25:55 UTC
"Can AWT code access PM.mutex()?" - yes. "Can someone holding PM.mutex() deal with AWT Tree Lock?" - no.
Comment 15 Tomas Zezula 2008-09-15 17:38:43 UTC
The deadlock was caused by change of threading in nb 6.1, the save of project properties is done outside the awt.
Comment 16 Tomas Zezula 2008-09-16 08:31:46 UTC
http://hg.netbeans.org/main/rev/a823ec3eab50
Comment 17 Quality Engineering 2008-09-16 17:34:49 UTC
Integrated into 'main-golden', will be available in build *200809161401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a823ec3eab50
User: Tomas Zezula <tzezula@netbeans.org>
Log: #145304:Unusable after project properties
Comment 18 Tomas Zezula 2008-09-17 14:51:28 UTC
Nicer fix:
http://hg.netbeans.org/main/rev/dced29ff7242
Comment 19 Quality Engineering 2008-09-18 05:32:05 UTC
Integrated into 'main-golden', will be available in build *200809180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/dced29ff7242
User: Tomas Zezula <tzezula@netbeans.org>
Log: #145304:Unusable after project properties


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo