Bug 144608 - --jdkhome ignored
--jdkhome ignored
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: t_h
issues@platform
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-20 16:48 UTC by Tomas Hurka
Modified: 2008-12-22 13:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Hurka 2008-08-20 16:48:29 UTC
--jdkhome is silently ignored if JDK home is specified by path which ends with backslash.

This does not work:
netbeans --jdkhome "C:\Program Files\Java\jdk1.5.0_13\"

this works fine:
netbeans --jdkhome "C:\Program Files\Java\jdk1.5.0_13"
Comment 1 Lukas Hasik 2008-08-21 08:11:07 UTC
easily reproducible
Comment 2 t_h 2008-08-21 13:13:38 UTC
Backslash is used for escaping quotation mark for command line options in Windows. "C:\Program Files\Java\jdk1.5.0_13\"
passed as command line parameter means [C:\Program Files\Java\jdk1.5.0_13"] - so in fact you are passing "invalid path".
I can detect such invalid option and "correct" it but in fact it is invalid parameter and not a bug.
Comment 3 Tomas Hurka 2008-08-21 13:46:07 UTC
You should detect invalid option and report it. Ignoring it silently is a bad practice. 
Comment 4 t_h 2008-08-21 15:16:46 UTC
3f484902cca0
Comment 5 Petr Chytil 2008-10-16 15:18:36 UTC
verified in:

Product Version: NetBeans IDE 6.5 RC1 (Build 200810151402)
Java: 1.5.0_12; Java HotSpot(TM) Client VM 1.5.0_12-b04
System: Windows Vista version 6.0 running on x86; Cp1250; cs_CZ (nb)
Userdir: C:\Users\tester\.netbeans\6.5rc1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo