Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 144038 - Mixed Java/Groovy sources in Web Application
Mixed Java/Groovy sources in Web Application
Status: RESOLVED FIXED
Product: groovy
Classification: Unclassified
Component: Code
6.x
All All
: P3 with 6 votes (vote)
: 7.3
Assigned To: Martin Janicek
issues@groovy
:
: 176140 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 11:31 UTC by mdbergmann
Modified: 2012-09-03 13:48 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mdbergmann 2008-08-15 11:32:00 UTC
Mixed Java and Groovy sources in a Web Application doesn't work.
While the editor/parser of the classes gives green light the ant build complains about unresolved classes.
This occurs when having references from Java to Groovy classes in the same or another package.
Comment 1 martin_adamek 2008-08-15 11:34:39 UTC
Groovy is not supported yet in web applications, but it would make sense to add it in the future. Unfortunately it's not possible for 6.5.
Comment 2 mdbergmann 2008-08-18 13:02:30 UTC
For JavaEE applications the business logic is actually not much different from a normal Java application.
The compiled classes go to WEB-INF/classes, that's it.

Hope to see this feature soon as some of our Web Applications have mixed Java/Groovy sources and we can't switch to NetBeans until this is supported.
Comment 3 giz80 2009-06-18 14:31:10 UTC
Is it possible to get this feature in the 6.7 release? It's required for us before we can switch to the netbeans ide.
Comment 4 Petr Hejl 2009-06-19 15:59:04 UTC
This certainly won't happen for 6.7 - we are in high resistence mode.
Comment 5 rfmoorejr 2010-09-16 22:46:09 UTC
Tried the mixed Java/Groovy classes on NetBeans IDE 6.9 RC2 (Build 201007282301). This still doesn't work (unresolved reference from Java to Groovy classes).

My test application was originally built on MyEclipse which apparently can support the mix. Maybe the NetBeans restriction on web applications is stated somewhere but I didn't see one in either NetBeans or Groovy sites.
Comment 6 Martin Janicek 2012-08-30 14:57:48 UTC
*** Bug 176140 has been marked as a duplicate of this bug. ***
Comment 7 Martin Janicek 2012-09-03 13:48:56 UTC
Fixed in:

Support for Web projects: http://hg.netbeans.org/web-main/rev/bb493a7aabbc
Support for EJB projects: http://hg.netbeans.org/web-main/rev/cdfe91d8ca3d
Cluster correction: http://hg.netbeans.org/web-main/rev/82fbea237e3b


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo