Bug 143941 - Test runner doesn't execute any test in RubyOnRails project
Test runner doesn't execute any test in RubyOnRails project
Status: RESOLVED FIXED
Product: ruby
Classification: Unclassified
Component: Testing
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-14 15:24 UTC by b0bben
Modified: 2008-08-15 14:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log test runner (39.36 KB, text/plain)
2008-08-15 07:51 UTC, b0bben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description b0bben 2008-08-14 15:24:24 UTC
(sorry for the bad choice of component, didn't know where this belongs)

When trying to invoke the test runner in 6.5 Beta via the project context menu, test runner reports the following:
Loaded suite C:/Program Files/NetBeans 6.5 Beta/ruby2/nb_test_mediator
Started

Finished in 0.0 seconds.

0 tests, 0 assertions, 0 failures, 0 errors

There are over 800 tests in the project.

If I open a test file and execute the "Test file" context menu command, the test runner will work and show failing/passing tests.

Environment:
Product Version: NetBeans IDE 6.5 Beta (Build 200808111757)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Windows XP version 5.1 running on x86; Cp1252; sv_SE (nb)
Userdir: C:\Documents and Settings\majeli\.netbeans\6.5beta
Comment 1 b0bben 2008-08-14 15:33:57 UTC
(changing component to ruby/testing)

Additional info about env:
* Ruby 1.8.6 p111
Comment 2 Erno Mononen 2008-08-14 15:41:41 UTC
The Test action in the context menu should run the rake test task, so does running rake test from the command line run 
those tests normally? Could you please also enable more detailed logging and then attach the IDE log file here as 
described at http://wiki.netbeans.org/FaqRubyNBLogging? Thanks!
Comment 3 b0bben 2008-08-15 07:51:55 UTC
Created attachment 67495 [details]
IDE log test runner
Comment 4 b0bben 2008-08-15 07:53:40 UTC
After restarting the IDE, I'm now getting an error instead: "c:\ruby\bin\ruby.exe: No such file or directory -- Files/NetBeans (LoadError)
"

Could this be related to: http://www.netbeans.org/issues/show_bug.cgi?id=140339 ?

Also, i've attached the IDE log with debugging enabled.

Cheers,
b0bben
Comment 5 b0bben 2008-08-15 07:55:32 UTC
Additional comment: rake test from the commandline works, as does autotest.
Comment 6 Erno Mononen 2008-08-15 14:39:24 UTC
Thanks, that helped. I've committed a fix for this, please give it a try when/if you have the chance. There should be 
an automatic notification here once the fix has been integrated, after that please grab a continuous build for testing 
-- see http://wiki.netbeans.org/RubyInstallation#section-RubyInstallation-HowDoIGetTheContinuousBuilds for more info.

The problem was caused by spaces in the path the NB's test runner, as a workaround you can move NB to a directory 
without spaces in the name.

Changeset d18a5d184d09.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo