Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 143851 - Find Usages takes EXTREMELY LONG to complete
Find Usages takes EXTREMELY LONG to complete
Status: VERIFIED FIXED
Product: groovy
Classification: Unclassified
Component: Editor
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: martin_adamek
issues@groovy
: PERFORMANCE, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-14 03:26 UTC by frankioski
Modified: 2008-10-30 14:25 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (50.01 KB, text/plain)
2008-08-14 03:32 UTC, frankioski
Details
Screen cap showing Find Usages hanging at 70% (105.34 KB, image/png)
2008-08-14 03:33 UTC, frankioski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description frankioski 2008-08-14 03:26:20 UTC
Build: 6.5 Beta
Processor: 2.59 GHz AMD Athlon 64 X2 Dual 5200+
RAM: 3GB
Free HD space: 117 GB

When doing Find Usages on a Java method name, the process takes extraordinarily long.  It typically hangs at 33%.  It
would complete minutes later (and there would only be just one usage occurrence).
Comment 1 frankioski 2008-08-14 03:32:24 UTC
Created attachment 67343 [details]
Thread dump
Comment 2 frankioski 2008-08-14 03:33:21 UTC
Created attachment 67344 [details]
Screen cap showing Find Usages hanging at 70%
Comment 3 Jan Becicka 2008-08-14 14:55:54 UTC
Groovy refactoring plugin factory should return null for projects, that does not contain groovy.
Comment 4 martin_adamek 2008-08-15 13:02:02 UTC
Groovy refactoring hooks up only if class is coming from groovy-enabled project.
http://hg.netbeans.org/main/rev/3b9ca9bd22d8
Comment 5 martin_adamek 2008-08-22 09:21:15 UTC
*** Issue 144727 has been marked as a duplicate of this issue. ***
Comment 6 Lukas Jungmann 2008-10-02 12:37:21 UTC
reporter, can I ask you to verify this, please? Thanks.
Comment 7 Lukas Jungmann 2008-10-13 14:35:35 UTC
v. Feel free to reopen when this appears again. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo