Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 143367 - Add option to disable Quicksearch provider
Add option to disable Quicksearch provider
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Quick Search
6.x
All All
: P3 with 1 vote (vote)
: 7.4
Assigned To: Jaroslav Havlin
issues@platform
:
: 138453 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-09 01:44 UTC by mbien
Modified: 2013-05-12 21:24 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Proposed Patch (22.93 KB, patch)
2013-01-18 09:34 UTC, Jaroslav Havlin
Details | Diff
Screenshots - compare current and proposed state (47.09 KB, image/png)
2013-01-18 09:35 UTC, Jaroslav Havlin
Details
Proposed Patch v2 (23.63 KB, patch)
2013-01-23 15:41 UTC, Jaroslav Havlin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mbien 2008-08-09 01:44:11 UTC
It should be possible for the user to disable selected quicksearch providers.

Quicksearch is a very powerful and easy to extend feature which may find fast adoption in third party plugins. The
problem is that it is not context sensitive. You don't want e.g mobile specific results when you are editing a webpage
or have websearch constantly enabled. In our case (NetBeans OpenGL Pack) we already provide four additional categories
(OpenGL SDK, OpenGL Extensions, two Vendor Extension categories and soon JOGL doc) and the problem starts right there.

proposed solution with best user experience:
-instead of having radio buttons in the drop down menu use checkboxes (checked means enabled)
-"enable all" and "disable all" menu items for easier use
-for power users there could be even the old mode trigged with the right mouse button which disables all categories
except the selected (same behaviour like now to have the best of both)

alternative:
list all quicksearch provider categories in the nb options and find a good way to disable them in ui (table with
checkboxes or similar)
Comment 1 markiewb 2012-10-13 20:53:15 UTC
*** Bug 138453 has been marked as a duplicate of this bug. ***
Comment 2 Jaroslav Havlin 2013-01-18 09:34:30 UTC
Created attachment 130350 [details]
Proposed Patch
Comment 3 Jaroslav Havlin 2013-01-18 09:35:25 UTC
Created attachment 130351 [details]
Screenshots - compare current and proposed state
Comment 4 Jaroslav Havlin 2013-01-18 09:38:53 UTC
I think that the enhancement is reasonable.
Thank you for reporting it.

CCing uireviews, please check the changes.

Left-click selects/deselects single category, right-click toggles "only this category enabled"/"only this category disabled, others enabled".
Comment 5 richgunther 2013-01-18 17:13:03 UTC
I like the proposed changes, but I'm somewhat skeptical about the right-click interaction.  That doesn't seem to be very discoverable, nor do I know if it's a standard behavior that users would expect to see.  Are there other UI examples that use this convention?
Comment 6 Jaroslav Havlin 2013-01-21 09:57:11 UTC
(In reply to comment #5)
> I like the proposed changes, but I'm somewhat skeptical about the right-click
> interaction.  That doesn't seem to be very discoverable, nor do I know if it's
> a standard behavior that users would expect to see.
Thank you, Rich. I implemented the right-click just because it was requested and it could be useful for a few users. It can be noted in help or in some blogs. I agree that majority of users will not discover it, but they won't probably need it.
Do you think the right-click should be removed, or can we leave it there for the minority of users that discover it and that find it useful?
Or would adding some tooltip help?

> Are there other UI examples that use this convention?
I'm not aware of any examples of this convention.
Comment 7 richgunther 2013-01-22 16:36:28 UTC
I think it's fine to leave it in there, and if we can add a tooltip that reads "Right-click to de-select all other categories", that would be great for discoverability's sake.

Rich
Comment 8 Jaroslav Havlin 2013-01-23 15:41:58 UTC
Created attachment 130540 [details]
Proposed Patch v2

Tooltips added.
Thank you, Rich.
Comment 9 Jaroslav Havlin 2013-01-29 10:53:01 UTC
Integrated as http://hg.netbeans.org/core-main/rev/0fc792112f38
Thanks for reporting and your comments.
Comment 10 Quality Engineering 2013-01-30 03:41:02 UTC
Integrated into 'main-golden', will be available in build *201301300001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0fc792112f38
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #143367: Add option to disable Quicksearch provider


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo