Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 142329 - Navigating up and down in a Groovy script is slow
Navigating up and down in a Groovy script is slow
Status: RESOLVED DUPLICATE of bug 152894
Product: groovy
Classification: Unclassified
Component: Editor
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: Petr Hejl
issues@groovy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 22:26 UTC by giorgio42
Modified: 2009-02-19 20:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description giorgio42 2008-07-30 22:26:59 UTC
NB 200807291401, WinXP SP2, 1.8GHz Centrino platform, 1GB RAM, 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b15

In a moderately sized Groovy script (< 200 lines) moving through the script lines using the up and down arrow keys is
slow. There is often a noticeable delay (half a second or so) when changing lines. This makes it impossible to move
quickly through the Groovy source using the keyboard. I have to use the mouse to scroll and click...

Regards,
Georg
Comment 1 Petr Hejl 2008-11-18 14:50:36 UTC
Do you think it would be possible to get a thread dump in such situation? Could be duplicate of issue 152894.
Comment 2 giorgio42 2009-01-12 20:28:15 UTC
In any case, 152894 is a duplicate of this, I should think!

However as both bug reports refer to the same issue and as 152894 has more content and is P2,
I do not mind declaring this bug a duplicate of 152894. What I care more about is that the bug is fixed
as soon as possible...

Comment 3 Petr Hejl 2009-01-12 20:37:32 UTC
We are working on rewrite to parsing api full time. It is our top priority.

*** This issue has been marked as a duplicate of 152894 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo